Bug 611857 - Using language highlights with programlisting drops zero (0) characters in the text
Summary: Using language highlights with programlisting drops zero (0) characters in th...
Status: CLOSED NOTABUG
Alias: None
Product: Publican
Classification: Community
Component: publican (Show other bugs)
(Show other bugs)
Version: 1.6
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Jeff Fearn
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-06 17:47 UTC by Deon Ballard
Modified: 2010-11-24 04:19 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-08 22:03:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Deon Ballard 2010-07-06 17:47:46 UTC
When I use syntax highlighting (any language), any 0s in the text within the <programlisting> tag is dropped from the HTML.

For example, I have...

<programlisting language="XML"><![CDATA[<?xml version="1.5"?>
<project name="test-bundle" default="main" 
    xmlns:rhq="antlib:org.rhq.bundle">

    <rhq:bundle name="example" version="1.0" description="an example bundle">]]>
</programlisting>

... in an example. In the HTML output, the 1.5 is correctly rendered, but the "1.0" is rendered as "1."

One oddity. I inserted this string, just to test:
0.4.0.5.87.0.0.0.5.6

And it was rendered as:
.4..5.87.0..0.5.6

I've tried this with and without CDATA and using different language types.

Info:
RHEL 5
publican-2.0-0.el5 (this also happened on 1.6 - the upgrade didn't fix it)
publican-redhat-2.0-0.el5
publican-jboss-1.9-0.el5

Comment 1 Ruediger Landmann 2010-07-06 23:06:04 UTC
I cannot reproduce this on Fedora 13. When I build that code example into a new Publican book, the output reads:

Chapter 1. Test Chapter

1.1. Test Section 1
1.2. Test Section 2

This is a test paragraph

<?xml version="1.5"?>
<project name="test-bundle" default="main" 
    xmlns:rhq="antlib:org.rhq.bundle">

    <rhq:bundle name="example" version="1.0" description="an example
bundle">


Note You need to log in before you can comment on or make changes to this bug.