Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 611893 - [PATCH] rmmod hangs when rmmod-ing i915 with modesetting enabled
[PATCH] rmmod hangs when rmmod-ing i915 with modesetting enabled
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-intel (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Adam Jackson
Desktop QE
: EasyFix, Patch, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-06 15:27 EDT by Lubomir Rintel
Modified: 2011-10-19 13:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-19 13:29:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A proposed fix (963 bytes, text/plain)
2010-07-06 15:29 EDT, Lubomir Rintel
no flags Details

  None (edit)
Description Lubomir Rintel 2010-07-06 15:27:54 EDT
Version-Release number of selected component (if applicable):

kernel-2.6.32-37.el6.i686

Steps to Reproduce:

# modprobe i915 modeset=1
# echo 0 >/sys/devices/virtual/vtconsole/vtcon1/bind
# rmmod i915
  
Actual results:

hang

Expected results:

module unloaded

Additional info:

crash> bt -l
PID: 1573   TASK: f5e75a90  CPU: 0   COMMAND: "rmmod"
 #0 [f2f0dd98] schedule at c0816a62
 #1 [f2f0de18] __mutex_lock_slowpath at c0817cb5
 #2 [f2f0de40] mutex_lock at c0817ba8
 #3 [f2f0de4c] drm_gem_object_free_unlocked at f7f5d9c7
    /usr/src/debug/kernel-2.6.32/linux-2.6.32.i686/drivers/gpu/drm/drm_gem.c: 469
 #4 [f2f0de5c] kref_put at c05dfe68
    /usr/src/debug/kernel-2.6.32/linux-2.6.32.i686/lib/kref.c: 68
 #5 [f2f0de68] intel_fbdev_destroy at f98cc78c
    /usr/src/debug/kernel-2.6.32/linux-2.6.32.i686/include/drm/drmP.h: 1466
 #6 [f2f0de74] intel_fbdev_fini at f98cc7c1
    /usr/src/debug/kernel-2.6.32/linux-2.6.32.i686/drivers/gpu/drm/i915/intel_fb.c: 260
 #7 [f2f0de7c] intel_modeset_cleanup at f98bfa83
    /usr/src/debug/kernel-2.6.32/linux-2.6.32.i686/drivers/gpu/drm/i915/intel_display.c: 4934
 #8 [f2f0de94] i915_driver_unload at f98a84ea
    /usr/src/debug/kernel-2.6.32/linux-2.6.32.i686/drivers/gpu/drm/i915/i915_dma.c: 1760
 #9 [f2f0deb0] drm_put_dev at f7f60d51
    /usr/src/debug/kernel-2.6.32/linux-2.6.32.i686/drivers/gpu/drm/drm_stub.c: 530
#10 [f2f0ded8] pci_device_remove at c05f7794
    /usr/src/debug/kernel-2.6.32/linux-2.6.32.i686/drivers/pci/pci-driver.c: 372
#11 [f2f0dee0] __device_release_driver at c06a29fb
    /usr/src/debug/kernel-2.6.32/linux-2.6.32.i686/drivers/base/dd.c: 328
#12 [f2f0deec] driver_detach at c06a2ae2
    /usr/src/debug/kernel-2.6.32/linux-2.6.32.i686/drivers/base/dd.c: 387
#13 [f2f0defc] bus_remove_driver at c06a1aa7
    /usr/src/debug/kernel-2.6.32/linux-2.6.32.i686/drivers/base/bus.c: 733
#14 [f2f0df1c] pci_unregister_driver at c05f79d6
    /usr/src/debug/kernel-2.6.32/linux-2.6.32.i686/drivers/pci/pci-driver.c: 1021
#15 [f2f0df30] drm_exit at f7f5c256
    /usr/src/debug/kernel-2.6.32/linux-2.6.32.i686/drivers/gpu/drm/drm_drv.c: 296
#16 [f2f0df4c] sys_delete_module at c0488d26
    /usr/src/debug/kernel-2.6.32/linux-2.6.32.i686/kernel/module.c: 870
#17 [f2f0dfb0] system_call at c04099d5
    /usr/src/debug////////kernel-2.6.32/linux-2.6.32.i686/arch/x86/kernel/entry_32.S: 529
    EAX: ffffffda  EBX: bfa78e50  ECX: 00000880  EDX: 08049b35
    DS:  007b      ESI: bfa78e50  ES:  007b      EDI: 00000880
    SS:  007b      ESP: bfa78e34  EBP: bfa78e98  GS:  0033
    CS:  0073      EIP: 00c0f416  ERR: 00000081  EFLAGS: 00000246
crash>
Comment 1 Lubomir Rintel 2010-07-06 15:29:44 EDT
Created attachment 429864 [details]
A proposed fix
Comment 3 RHEL Product and Program Management 2010-07-15 10:34:51 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 4 RHEL Product and Program Management 2011-01-06 23:27:14 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 5 Suzanne Yeghiayan 2011-01-07 11:22:12 EST
This request was erroneously denied for the current release of Red Hat
Enterprise Linux.  The error has been fixed and this request has been
re-proposed for the current release.
Comment 6 RHEL Product and Program Management 2011-01-11 10:28:47 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 7 RHEL Product and Program Management 2011-02-01 01:06:39 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 8 RHEL Product and Program Management 2011-02-01 13:27:02 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 9 RHEL Product and Program Management 2011-04-03 22:34:31 EDT
Since RHEL 6.1 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 10 RHEL Product and Program Management 2011-10-07 12:14:30 EDT
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 11 Adam Jackson 2011-10-19 13:29:18 EDT
I'm unable to reproduce this in current 6.2 kernels, closing.

Note You need to log in before you can comment on or make changes to this bug.