Bug 611929 - corosync 2801 introduces need for compat patch in rhel to roll
Summary: corosync 2801 introduces need for compat patch in rhel to roll
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openais (Show other bugs)
(Show other bugs)
Version: 5.5
Hardware: All Linux
urgent
urgent
Target Milestone: rc
: ---
Assignee: Steven Dake
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords: ZStream
Depends On: 606028
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-06 21:15 UTC by Benjamin Kahn
Modified: 2016-04-26 15:59 UTC (History)
8 users (show)

Fixed In Version: openais-0.80.3-22.el5_3.15
Doc Type: Bug Fix
Doc Text:
Previously, openais ended in a segmentation fault when it received cpg messages. This occurred because the ids introduced by corosync were incompatible with the cpg messages. With this update, a new code was added and cpg messages are now compatible with corosync.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-05 15:25:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2010:0828 normal SHIPPED_LIVE openais bug fix update 2010-11-05 15:25:37 UTC

Description Benjamin Kahn 2010-07-06 21:15:15 UTC
This bug has been copied from bug #606028 and has been proposed
to be backported to 5.3 z-stream (EUS).

Comment 4 Florian Nadge 2010-10-18 17:00:40 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, openais ended in a segmentation fault when it received cpg messages. This occurred because the ids introduced by corosync were incompatible with the cpg messages. With this update, a new code was added and cpg messages are now compatible with corosync.

Comment 5 Jaroslav Kortus 2010-11-05 13:10:56 UTC
RHEL6 node can now successfully join rhel5.5 cluster. Marking as verified.

Comment 7 errata-xmlrpc 2010-11-05 15:25:45 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0828.html


Note You need to log in before you can comment on or make changes to this bug.