Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 612080 - virt-v2v actually doesn't install virtio drivers(network and block)
virt-v2v actually doesn't install virtio drivers(network and block)
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-v2v (Show other bugs)
5.5
x86_64 Linux
medium Severity high
: rc
: ---
Assigned To: Matthew Booth
Virtualization Bugs
:
Depends On:
Blocks: 612091
  Show dependency treegraph
 
Reported: 2010-07-07 05:37 EDT by cshao
Modified: 2010-07-15 07:18 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 612091 (view as bug list)
Environment:
Last Closed: 2010-07-15 06:50:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
2K8-64-conversion.log (2.12 KB, text/plain)
2010-07-07 05:37 EDT, cshao
no flags Details
2K8-64-conversion_debug.log (2.12 KB, text/plain)
2010-07-07 05:38 EDT, cshao
no flags Details
2k8-64-error snapshot (302.91 KB, application/x-gzip)
2010-07-07 05:47 EDT, cshao
no flags Details

  None (edit)
Description cshao 2010-07-07 05:37:48 EDT
Created attachment 430007 [details]
2K8-64-conversion.log

Description of problem:
virt-v2v actually doesn't install virtio drivers(network and block).

Version-Release number of selected component (if applicable):
virt-v2v
libguestfs

How reproducible:
100%

Steps to Reproduce:
1. run V2V to convert Windows guest
   (virt-v2v -i libvirtxml -ic xen://system -o rhev -osd path 2k8-64b-hv-raw-intel.xml).
2. in RHEVM, run 2k8-64b-hv-raw virtual machine.
3. choose device manager->Disk drivers->Red Hat Virtio Scsi Disk Device properties->Driver tab.
4. choose ok or cancel button, and then choose reboot in system settings change dialog windows.
5. Please see attachment for more details.
  
Actual results:
virt-v2v actually doesn't install virtio drivers(network and block)

Expected results:
virt-v2v can install virtio's driver.

Additional info:
Comment 1 cshao 2010-07-07 05:38:43 EDT
Created attachment 430008 [details]
2K8-64-conversion_debug.log
Comment 2 cshao 2010-07-07 05:47:32 EDT
Created attachment 430013 [details]
2k8-64-error snapshot
Comment 3 Rita Wu 2010-07-07 05:59:06 EDT
It occurs on virt-v2v-0.6.1-1.el5,libguestfs-1.2.7-1.el5.6 and perl-libguestfs-1.2.7-1.el5.6

After conversion, there are several issue we find:

1. "Found New Device" will pop up When login Windows guest.
2. Virtio Network driver isn't installed, so there is an exclamation mark in "Device Manager"
3. Although there is no exclamation mark with block, the driver info from "ISCSI Controller Properties" is unkown 

For details, pls see the above attachment.
Comment 4 Richard W.M. Jones 2010-07-07 07:41:06 EDT
Matt is away until 2010-07-13.  However virt-v2v itself is not
meant to install virtio network drivers.  We rely on RHEV-M to
do that for us.

What is supposed to happen:

(1) virt-v2v installs virtio block driver.
(2) virt-v2v installs CDUpgrader (RHEV-M component).
(3) virt-v2v makes some changes to the registry so that
  virtio block driver is included in the CriticalDeviceDatabase
  (Registry) and so that CDUpgrader service will be started
  at next boot.

--- after this point virt-v2v has finished ---

(4) Windows guest is imported and booted in RHEV-M.
(5) RHEV-M attaches a driver CD to the guest.
(6) CDUpgrader notices the driver CD and installs all
  the virtio drivers from it (including reinstalling the
  virtio block driver "properly").
Comment 5 Hugh Brock 2010-07-07 15:08:43 EDT
Indeed, please note also that CDUpgrader takes quite a while to complete, and also that you must have the RHEV-M tools iso available for CDUpgrader to work. I believe this is all in the man page.

--Hugh
Comment 6 Lawrence Lim 2010-07-08 08:05:55 EDT
We need to ensure this is in the *Guide
Comment 7 Richard W.M. Jones 2010-07-08 08:26:37 EDT
(In reply to comment #6)
> We need to ensure this is in the *Guide    

I agree.

If only I could find the V2V documentation BZ ...
Comment 8 Rita Wu 2010-07-08 22:39:51 EDT
I cannot find related info in v2v man page either RHEL5 or RHEL6 and V2V document (http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6/html-single/Virtualization/#chap-Virtualization-v2v-migration).
Comment 9 Rita Wu 2010-07-09 00:09:15 EDT
(In reply to comment #4)
> Matt is away until 2010-07-13.  However virt-v2v itself is not
> meant to install virtio network drivers.  We rely on RHEV-M to
> do that for us.
> 
> What is supposed to happen:
> 
> (1) virt-v2v installs virtio block driver.
> (2) virt-v2v installs CDUpgrader (RHEV-M component).
> (3) virt-v2v makes some changes to the registry so that
>   virtio block driver is included in the CriticalDeviceDatabase
>   (Registry) and so that CDUpgrader service will be started
>   at next boot.
> 
> --- after this point virt-v2v has finished ---
> 
> (4) Windows guest is imported and booted in RHEV-M.
> (5) RHEV-M attaches a driver CD to the guest.
> (6) CDUpgrader notices the driver CD and installs all
>   the virtio drivers from it (including reinstalling the
>   virtio block driver "properly").    

Oh, got it. But even the virtio block drivers cannot install properly, so although there is no exclamation mark with block, the driver info from
"ISCSI Controller Properties" is unkown. and sometime Windows will become blue screen after reboot then we can never boot it any more.
Comment 10 Richard W.M. Jones 2010-07-09 03:48:24 EDT
(In reply to comment #9) 
> Oh, got it. But even the virtio block drivers cannot install properly, so
> although there is no exclamation mark with block, the driver info from
> "ISCSI Controller Properties" is unkown. and sometime Windows will become blue
> screen after reboot then we can never boot it any more.    

This shouldn't be happening ..  Matt is back in two days.
Comment 11 Jinxin Zheng 2010-07-09 06:37:51 EDT
Rich, Matt, can you suggest how we can find out the status and log of the CDUpgrader service?

Sometimes I doubt the service is not functioning properly. It would be much better if we know how it works.
Comment 12 Richard W.M. Jones 2010-07-09 06:45:11 EDT
Amos, in reply to comment 11 where / does CDUpgrader have
any sort of logging?
Comment 13 Amos Benari 2010-07-11 06:35:51 EDT
CDUpgrader has a logging mechanism, it uses windows shell wsh.LogEvent.
The log can be found in windows event log under the applications section. The application name is 'wsh' because the CDUpgrader is a script that runs from shell.
Please note that the CDUpgrader check the content of the CD only at boot time.
Comment 14 David Jorm 2010-07-12 02:43:35 EDT
(In reply to comment #4)
> Matt is away until 2010-07-13.  However virt-v2v itself is not
> meant to install virtio network drivers.  We rely on RHEV-M to
> do that for us.
> 
> What is supposed to happen:
> 
> (1) virt-v2v installs virtio block driver.
> (2) virt-v2v installs CDUpgrader (RHEV-M component).
> (3) virt-v2v makes some changes to the registry so that
>   virtio block driver is included in the CriticalDeviceDatabase
>   (Registry) and so that CDUpgrader service will be started
>   at next boot.
> 
> --- after this point virt-v2v has finished ---
> 
> (4) Windows guest is imported and booted in RHEV-M.
> (5) RHEV-M attaches a driver CD to the guest.
> (6) CDUpgrader notices the driver CD and installs all
>   the virtio drivers from it (including reinstalling the
>   virtio block driver "properly").    

I have added this to the RHEV Admin Guide appendix on virt-v2v:

http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Enterprise_Virtualization_for_Servers/2.2/html/Administration_Guide/virt-v2v-scripts.html#id2742936

I have not added it to the RHEL Virtualization Guide, since RHEV is required for Windows guests.
Comment 15 Matthew Booth 2010-07-14 12:25:21 EDT
Linglu,

Can you please run this one again from the start? Can you ensure that the Guest Tools are imported in RHEV before booting the guest the first time (I think this is done now), and also ensure that on first boot you don't log in until the guest's CPU usage has dropped to idle.

Thanks
Comment 16 cshao 2010-07-14 21:38:42 EDT
We will retest the windows with new steps today.
Thanks.
Comment 17 Mohua Li 2010-07-15 06:50:40 EDT
retest again with the iso file available, the windows guest (win2003, win2008, win7) could install the network driver, block driver, so this is not a bug,
Comment 18 Mohua Li 2010-07-15 06:57:24 EDT
but there is still some problem, like, bug 614792,we will always use a new bug to track any fail in the test.
Comment 19 Matthew Booth 2010-07-15 07:18:45 EDT
(In reply to comment #18)
> but there is still some problem, like, bug 614792,we will always use a new bug
> to track any fail in the test.    

I'm expecting plenty of general robustness bugs. Just glad to see it at least basically works first, though!

Note You need to log in before you can comment on or make changes to this bug.