Bug 612086 - selinux mount tmpfs: mount: foo not mounted already, or bad option
Summary: selinux mount tmpfs: mount: foo not mounted already, or bad option
Status: CLOSED DUPLICATE of bug 561111
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Eric Paris
QA Contact: Petr Beňas
URL:
Whiteboard:
Keywords:
Depends On: 592327
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-07 09:43 UTC by Petr Beňas
Modified: 2015-01-04 22:59 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-09 22:50:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Petr Beňas 2010-07-07 09:43:34 UTC
Description of problem:
mount -t tmpfs -o remount,mpol=default tmpfs ryan leads to remount fail with selinux enforcing.

Version-Release number of selected component (if applicable):
2.6.32-37.el6.ppc64 tested on ppc, expect it is reproducible on all archs

How reproducible:
always

Steps to Reproduce:
selinux enforcing:
[root@ibm-js22-vios-02-lp1 ~]# uname -r
2.6.32-37.el6.ppc64
[root@ibm-js22-vios-02-lp1 ~]# mkdir ryan
[root@ibm-js22-vios-02-lp1 ~]# mount -t tmpfs tmpfs ryan
[root@ibm-js22-vios-02-lp1 ~]# mount | grep ryan
tmpfs on /root/ryan type tmpfs (rw,rootcontext="unconfined_u:object_r:admin_home_t:s0")
[root@ibm-js22-vios-02-lp1 ~]# mount -t tmpfs -o remount,mpol=default tmpfs ryan
mount: ryan not mounted already, or bad option

selinux fully disabled(/etc/selinux/config to disabled and reoot)
[root@ibm-js22-vios-02-lp1 ~]# uname -r
2.6.32-37.el6.ppc64
[root@ibm-js22-vios-02-lp1 ~]# mkdir -p ryan
[root@ibm-js22-vios-02-lp1 ~]# mount -t tmpfs tmpfs ryan
[root@ibm-js22-vios-02-lp1 ~]# mount | grep ryan
tmpfs on /root/ryan type tmpfs (rw)                                            n
[root@ibm-js22-vios-02-lp1 ~]# mount -t tmpfs -o remount,mpol=default tmpfs ryan 
[root@ibm-js22-vios-02-lp1 ~]# mount | grep ryan
tmpfs on /root/ryan type tmpfs (rw,mpol=default)
  
Actual results:
mount: ryan not mounted already, or bad option

Expected results:
tmpfs on /root/ryan type tmpfs (rw,mpol=default)

Additional info:

Comment 2 Eric Paris 2010-07-09 22:24:33 UTC
looks like a dup of 561111

Comment 3 Eric Paris 2010-07-09 22:50:22 UTC

*** This bug has been marked as a duplicate of bug 561111 ***


Note You need to log in before you can comment on or make changes to this bug.