Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 612091 - virt-v2v actually doesn't install virtio drivers for network
virt-v2v actually doesn't install virtio drivers for network
Status: CLOSED DUPLICATE of bug 615981
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-v2v (Show other bugs)
6.0
x86_64 Linux
medium Severity high
: rc
: ---
Assigned To: Matthew Booth
Virtualization Bugs
:
Depends On: 612080
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-07 06:02 EDT by Rita Wu
Modified: 2013-07-02 21:40 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 612080
Environment:
Last Closed: 2010-07-20 04:14:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rita Wu 2010-07-07 06:02:08 EDT
It also occurs in RHEL6.

Version-Release number of selected component
virt-v2v-0.6.1-1.el6.x86_64
libguestfs-1.2.7-1.el6.5.x86_64
libguestfs-winsupport-1.0-5.el6.x86_64
perl-libguestfs-1.2.7-1.el6.5.x86_64


+++ This bug was initially created as a clone of Bug #612080 +++

Created an attachment (id=430007)
2K8-64-conversion.log

Description of problem:
virt-v2v actually doesn't install virtio drivers(network and block).

Version-Release number of selected component (if applicable):
virt-v2v
libguestfs

How reproducible:
100%

Steps to Reproduce:
1. run V2V to convert Windows guest
   (virt-v2v -i libvirtxml -ic xen://system -o rhev -osd path 2k8-64b-hv-raw-intel.xml).
2. in RHEVM, run 2k8-64b-hv-raw virtual machine.
3. choose device manager->Disk drivers->Red Hat Virtio Scsi Disk Device properties->Driver tab.
4. choose ok or cancel button, and then choose reboot in system settings change dialog windows.
5. Please see attachment for more details.
  
Actual results:
virt-v2v actually doesn't install virtio drivers(network and block)

Expected results:
virt-v2v can install virtio's driver.

Additional info:

--- Additional comment from cshao@redhat.com on 2010-07-07 05:38:43 EDT ---

Created an attachment (id=430008)
2K8-64-conversion_debug.log

--- Additional comment from cshao@redhat.com on 2010-07-07 05:47:32 EDT ---

Created an attachment (id=430013)
2k8-64-error snapshot

--- Additional comment from rwu@redhat.com on 2010-07-07 05:59:06 EDT ---

It occurs on virt-v2v-0.6.1-1.el5,libguestfs-1.2.7-1.el5.6 and perl-libguestfs-1.2.7-1.el5.6

After conversion, there are several issue we find:

1. "Found New Device" will pop up When login Windows guest.
2. Virtio Network driver isn't installed, so there is an exclamation mark in "Device Manager"
3. Although there is no exclamation mark with block, the driver info from "ISCSI Controller Properties" is unkown 

For details, pls see the above attachment.
Comment 2 RHEL Product and Program Management 2010-07-15 11:02:59 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 3 Rita Wu 2010-07-20 04:14:50 EDT
More specified description is in Bug 615981.

*** This bug has been marked as a duplicate of bug 615981 ***

Note You need to log in before you can comment on or make changes to this bug.