Bug 612103 - Livelock when acting as NFS server (nfs v3 exports) on 2.6.18-194.3.1.el5
Summary: Livelock when acting as NFS server (nfs v3 exports) on 2.6.18-194.3.1.el5
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
(Show other bugs)
Version: 5.5
Hardware: All Linux
low
urgent
Target Milestone: rc
: ---
Assignee: Red Hat Kernel Manager
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-07 10:25 UTC by olaf
Modified: 2018-03-19 12:14 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 13:24:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
part of /var/log/messages (25.18 KB, text/plain)
2010-07-07 10:25 UTC, olaf
no flags Details
part of /var/log/messages (2nd issue) (24.85 KB, application/octet-stream)
2010-07-07 10:26 UTC, olaf
no flags Details

Description olaf 2010-07-07 10:25:28 UTC
Created attachment 430021 [details]
part of /var/log/messages

OS: CentOS 5.5 x86_64

I attache /var/log/messages.
The system was working but any access to affected filesystem caused the accessing process to block.
To get it to normal state again a reset was necessary (reboot hung of course).

The filesystem that was exported was stacked as below:
RAID1->LUKS->LVM->Ext3.

I had 2 such issues.

I had similar issue in the past using nfs v4 exports. Bug #612101

Comment 1 olaf 2010-07-07 10:26:31 UTC
Created attachment 430022 [details]
part of /var/log/messages (2nd issue)

Comment 2 olaf 2010-07-07 10:30:38 UTC
Also reported in CentOS bugzilla:

http://bugs.centos.org/view.php?id=4405

Comment 4 RHEL Product and Program Management 2014-03-07 13:57:20 UTC
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.

Comment 5 RHEL Product and Program Management 2014-06-02 13:24:11 UTC
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).


Note You need to log in before you can comment on or make changes to this bug.