Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 612116 - [virt-v2v] v2v doesn't install the software package for win7 conversion in rhel6
[virt-v2v] v2v doesn't install the software package for win7 conversion in rhel6
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-v2v (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Matthew Booth
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-07 06:54 EDT by Mohua Li
Modified: 2013-04-30 19:13 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-15 11:30:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohua Li 2010-07-07 06:54:33 EDT
Description of problem:

in rhel6, v2v support win7 guest conversion, in rhel 5 didn't,

cat /etc/virt-v2v.conf,

 </app>
  <app os='windows' major='6' minor='1' arch='i386' name='viostor'>
    <path>windows/7/i386/viostor.sys</path>
  </app>
  <app os='windows' major='6' minor='1' arch='x86_64' name='viostor'>
    <path>windows/7/x86_64/viostor.sys</path>
  </app>



but v2v didn't install the package for win7 conversion,

"virt-v2v: Installation failed because the following files referenced in the configuration file are required, but missing: windows/7/i386/viostor.sys

Error: Convert image /media/92aedf46-6639-4664-8844-99f47830447e/cleankvm/raw/win7-32.raw failed"


[root@dhcp-66-70-198 virt-v2v]# cd software/windows/
[root@dhcp-66-70-198 windows]# ls
2003  2008  firstboot.bat  rhev-apt.exe  rhsrvany.exe  xp 


detail, pls see below,

virt-v2v -f /etc/virt-v2v.conf -o rhev -osd 10.66.90.115:/vol/v2vwulinglu/wulingluv2v/fcp_export win7-32.raw

add_drive_with_if "/tmp/en7HJQBfg8/5404c974-b393-4853-a67a-895d8adb4332/v2v.nNHCaJst/b1f02f75-0d82-4e14-a3f9-26730be23360/d077935c-6f64-4869-a8fa-ffdb5c2829cc" "ide"

add_drive_ro_with_if "/var/lib/virt-v2v/transfer.iso" "ide"

launch

set_autosync true

list_partitions

pvs

available "lvm2"

lvs

file "/dev/sda1"

mount_ro "/dev/sda1" "/"

is_file "/grub/menu.lst"

is_file "/grub/grub.conf"

is_dir "/etc"

is_dir "/etc"

is_dir "/etc"

is_file "/AUTOEXEC.BAT"

is_file "/autoexec.bat"

is_dir "/Program Files"

is_dir "/WINDOWS"

is_file "/boot.ini"

is_file "/ntldr"

umount_all

file "/dev/sda2"

mount_ro "/dev/sda2" "/"

is_file "/grub/menu.lst"

is_file "/grub/grub.conf"

is_dir "/etc"

is_dir "/etc"

is_dir "/etc"

is_file "/AUTOEXEC.BAT"

is_file "/autoexec.bat"

case_sensitive_path "/boot.ini"

case_sensitive_path "/windows/system32"

case_sensitive_path "/windows"

case_sensitive_path "/Windows/system32/cmd.exe"

file "/Windows/System32/cmd.exe"

case_sensitive_path "/Windows/system32/config"

case_sensitive_path "/Windows/System32/config/software"

download "/Windows/System32/config/SOFTWARE" "/tmp/bTsTrbfbRE/software"

case_sensitive_path "/Windows/System32/config/system"

download "/Windows/System32/config/SYSTEM" "/tmp/bTsTrbfbRE/system"

umount_all

mount_options "" "/dev/sda2" "/"

mkdir "/temp"

mkdir "/temp/v2v"

mkdtemp "/transferXXXXXX"

list_devices

mount_ro "/dev/sdb" "/transferQHGRBc"

exists "/transferQHGRBc/windows/7/i386/viostor.sys"

exists "/transferQHGRBc/windows/firstboot.bat"

exists "/transferQHGRBc/windows/rhev-apt.exe"

exists "/transferQHGRBc/windows/rhsrvany.exe"

umount "/transferQHGRBc"

rmdir "/transferQHGRBc"

umount_all

sync

kill_subprocess

virt-v2v: Installation failed because the following files referenced in the configuration file are required, but missing: windows/7/i386/viostor.sys

Error: Convert image /media/92aedf46-6639-4664-8844-99f47830447e/cleankvm/raw/win7-32.raw failed

Domain win7-32.raw has been undefined

[root@dhcp-66-70-198 v2v]# cd /var/lib/virt-v2v

[root@dhcp-66-70-198 virt-v2v]# ls

software  transfer.iso

[root@dhcp-66-70-198 virt-v2v]# cd software/windows/

[root@dhcp-66-70-198 windows]# ls

2003  2008  firstboot.bat  rhev-apt.exe  rhsrvany.exe  xp






Version-Release number of selected component (if applicable):
rhel 6, libguestfs-1.2.7-1.el6.5.x86_64,libguestfs-winsupport-1.0-5.el6.x86_64,


How reproducible:
always

Steps to Reproduce:
1.$above
2.
3.
  
Actual results:
see $above

Expected results:
install the package for win7 conversion, 

Additional info:
Comment 2 RHEL Product and Program Management 2010-07-15 11:02:55 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 3 Matthew Booth 2010-07-15 11:30:35 EDT
The configuration file is out of date as the RHEL 6 package no longer contains this directive. Please check /etc/virt-v2v.conf is the version delivered by the package with rpm -V, and reinstall if necessary.

This directive was erroneously included in an older version of the config file. It is possible that the config has been updated with a copy based on the older version.

Note You need to log in before you can comment on or make changes to this bug.