Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 612126 - bash can't handle moved binaries well
bash can't handle moved binaries well
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: bash (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Roman Rakus
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-07 07:28 EDT by Michal Hlavinka
Modified: 2014-01-12 19:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-23 08:39:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Hlavinka 2010-07-07 07:28:04 EDT
Description of problem:
bash uses hash table to speed up searching of binaries in PATH, but when binary is moved, bash reports "not found" instead of trying to search again.

Version-Release number of selected component (if applicable):
bash-4.1.2-3.el6.x86_64
bash-4.1.7-1.fc13.x86_64


How reproducible:
always

Steps to Reproduce:
# cp /bin/grep /usr/bin/grep
# grep
# type grep 
grep is hashed (/usr/bin/grep)
# rm /usr/bin/grep
# grep


Actual results:
bash: /usr/bin/grep: No such file or directory

Expected results:
no error
bash should just remove entry from hash table and look for grep again using PATH
Comment 2 Roman Rakus 2010-07-23 08:39:50 EDT
This has been already discussed on the upstream mailing list; see http://www.mail-archive.com/bug-bash@gnu.org/msg06799.html
Comment 3 Michal Hlavinka 2010-07-26 07:55:26 EDT
well, that discussion on the upstream mailing list is slightly different.

mailing list:
PATH=a:b:...
binary in b
add binary in a
-> b is still used

I understand upstream explanation that it'd made hashtable useless if you have to check path all the time, but this is not the bug I'm describing here, because in that case you still can use some binary. Well, discussion if different binary (mailing list case)


my bug report:
remove item from hash table if execution fails because file was removed and this should be pretty well doable and you'll still be able to use hashtable for better performance. When I got this error, it was because some package moved its binary file to different place which resulted in disappearing from bash completely. It took some time to find out what's happening, because the "only" result I got was /usr/bin/binary = "not found" vs. which binary = /usr/bin/binary

hashtable should be also cleared when PATH variable is changed (don't know if this is not already happening, did no test)

Because this bug is not the same as mentioned in the mailing list and fixing this would not prevent using hashtable for its purpose, I think this bug should be reopened.
Comment 4 Roman Rakus 2010-07-26 09:00:15 EDT
One thing you missed; the `checkhash'. Try to enable this option with shopt. Yeah, it is not set by default...

Note You need to log in before you can comment on or make changes to this bug.