Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 612183 - kdump should compress and strip by default
kdump should compress and strip by default
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kexec-tools (Show other bugs)
6.0
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Cong Wang
Boris Ranto
:
Depends On: 614379
Blocks: 988414
  Show dependency treegraph
 
Reported: 2010-07-07 09:50 EDT by Andrew Hecox
Modified: 2013-09-29 22:18 EDT (History)
11 users (show)

See Also:
Fixed In Version: kexec-tools-2_0_0-113_el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 988414 (view as bug list)
Environment:
Last Closed: 2010-11-11 09:42:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (4.46 KB, patch)
2010-07-13 03:37 EDT, Cong Wang
no flags Details | Diff

  None (edit)
Description Andrew Hecox 2010-07-07 09:50:47 EDT
currently, kdump defaults to using cp --sparse; it should strip and compress by default. Stripping levels of 19 and 31 have been discussed, both are fine from GSS's perspective (and are used in the field) and we're happy to help do additional research on which is most appropriate.
Comment 1 Cong Wang 2010-07-09 00:19:14 EDT
Really? I get:

RHEL-6/kdump.conf:106:#core_collector makedumpfile -c --message-level 1
RHEL-6/kdump.conf:107:#core_collector cp --sparse=always

I think you mean to add -d 31 to makedumpfile, right? Note, -c already does compression.
Comment 2 Neil Horman 2010-07-09 07:04:14 EDT
amerigo, those lines are examples in kdump.conf, and are commented out by default.  The capture function save_core in /etc/init.d/kdump uses cp --sparse=always to caputer core.  We need to change the initscript and kdump.conf defaults to using makedumpfile.
Comment 3 Cong Wang 2010-07-12 06:32:57 EDT
Ah, got it. Thanks Neil! (Cancel need_info.)
Comment 4 Cong Wang 2010-07-13 03:37:18 EDT
Created attachment 431377 [details]
Proposed patch

Neil, please check if this patch is what you need.
It does more than what you said, it even replaces the default 'cp' with 'makedumpfile ...' when dumping to a local host or NFS host.
Comment 5 Neil Horman 2010-07-13 07:13:55 EDT
It looks more  or less fine to me.  A few notes though:

1) It seems like changing te default in kdump.conf and in mkdumprd is doing the same thing twice.  It doesn't hurt anything, but since you're changing the default in mkdumprd you can likely leave the kdump.conf setting commented out (or change it to an alternate core_collector implementation).  You don't have to, just something to think about

2) This patch doesn't cause this, but looking at it I notice that setting CORE_COLLECTOR to cp doesn't work with ssh targets, since it expects CORE_COLLECTOR to copy data to stdout.  Might want to look at doing something about that (although I'm not sure what quite yet).
Comment 7 Cong Wang 2010-07-13 22:47:17 EDT
(In reply to comment #5)
> It looks more  or less fine to me.  A few notes though:
> 
> 1) It seems like changing te default in kdump.conf and in mkdumprd is doing the
> same thing twice.  It doesn't hurt anything, but since you're changing the
> default in mkdumprd you can likely leave the kdump.conf setting commented out
> (or change it to an alternate core_collector implementation).  You don't have
> to, just something to think about


Somewhat, the default in mkdumprd happens only when there is no CORE_COLLECTOR in kdump.conf, while the default in kdump.conf is recommended for users to use.

Anyway, I will comment that out.

> 
> 2) This patch doesn't cause this, but looking at it I notice that setting
> CORE_COLLECTOR to cp doesn't work with ssh targets, since it expects
> CORE_COLLECTOR to copy data to stdout.  Might want to look at doing something
> about that (although I'm not sure what quite yet).    

Hmm, good point. How about opening another BZ for it? This BZ is for snap8, it is a bit late to fix this issue in this BZ, I think.

Thanks.
Comment 10 Cong Wang 2010-07-14 00:37:36 EDT
(In reply to comment #7)
> > 2) This patch doesn't cause this, but looking at it I notice that setting
> > CORE_COLLECTOR to cp doesn't work with ssh targets, since it expects
> > CORE_COLLECTOR to copy data to stdout.  Might want to look at doing something
> > about that (although I'm not sure what quite yet).    
> 
> Hmm, good point. How about opening another BZ for it? This BZ is for snap8, it
> is a bit late to fix this issue in this BZ, I think.

Done, it's Bug 614303.
Comment 13 releng-rhel@redhat.com 2010-11-11 09:42:45 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.