Bug 612254 - cinepaint crash vreating new file
cinepaint crash vreating new file
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cinepaint (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Nicolas Chauvet (kwizart)
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-07 13:02 EDT by Stefan Jensen
Modified: 2011-02-22 03:33 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-22 03:33:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Jensen 2010-07-07 13:02:50 EDT
Description of problem:

Cinepaint will crash, if i create a new file from menu

Version-Release number of selected component (if applicable):

cinepaint-0.22.1-14.fc12.x86_64
cinepaint-libs-0.22.1-14.fc12.x86_64

How reproducible:

Always

Steps to Reproduce:
1. Start cinepaint
2. Select "File" -> "New" -> "OK"
3. cinepaint crash
  
Actual results:

cinepaint exit

Expected results:

new file created for editing.

Additional info:


$ LANG=C cinepaint

Locale found in /usr/share/locale

(cinepaint:7509): Gtk-WARNING **: A floating object was finalized. This means that someone
called g_object_unref() on an object that had only a floating
reference; the initial floating reference is not owned by anyone
and must be removed with g_object_ref_sink().
WARNING: /builddir/build/BUILD/oyranos-0.1.9/oyranos.c:253 oyGetPathFromProfileName_() profile not found in colour path: sRGB.icc[-1] 

cinepaint: Cannot open selected ICC assumed image profile: sRGB.icc
WARNING: /builddir/build/BUILD/oyranos-0.1.9/oyranos.c:253 oyGetPathFromProfileName_() profile not found in colour path: sRGB.icc[-1] 

cinepaint: Cannot open selected ICC editing profile: sRGB.icc
WARNING: /builddir/build/BUILD/oyranos-0.1.9/oyranos.c:253 oyGetPathFromProfileName_() profile not found in colour path: sRGB.icc[-1] 

WARNING: /builddir/build/BUILD/oyranos-0.1.9/oyranos_io.c:143 oyReadFileToMem_() could not read: "sRGB.icc"
[-1] 

WARNING: /builddir/build/BUILD/oyranos-0.1.9/oyranos_alpha.c:6598 oyProfile_FromMemMove_() Did not find monitor profile; nor a substitute.[-1] 

WARNING: /builddir/build/BUILD/oyranos-0.1.9/oyranos_alpha.c:6625 oyProfile_FromMemMove_() hash error 1[-1] 

cms.c:466 cms_init_oyranos() monitor profile size: 0
WARNING: /builddir/build/BUILD/oyranos-0.1.9/oyranos.c:253 oyGetPathFromProfileName_() profile not found in colour path: coated_FOGRA39L_argl.icc[-1] 

cinepaint: Cannot open selected ICC default proof profile: coated_FOGRA39L_argl.icc
Searching plug-ins in path: /home/jensen/.cinepaint/plug-ins/:/usr/lib64/cinepaint/0.22-1/plug-ins
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/spread
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/tga
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/bracketing_to_hdr
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/collect
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/snoise
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/screenshot
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/fits
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/clothify.py
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/pic
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/sphere.py
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/gimpcons.py
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/icc_examin_cp
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/psd
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/png
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/foggify.py
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/print
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/gtkcons.py
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/tiff
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/decompose
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/bmp
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/noisify
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/rawphoto
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/gbr
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/xwd
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/minimum
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/gifload
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/psd_save
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/cineon
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/retinex
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/edge
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/hdr
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/compose
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/sobel
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/openexr
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/unsharp
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/rotate
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/blur
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/gauss_rle
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/dicom
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/dbbrowser
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/whirlpinch.py
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/script-fu
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/jpeg
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/median
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/sharpen
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/sgi
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/iff
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/mblur
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/pnm
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/pdf
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/shadow_bevel.py
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/pdbbrowse.py
Loading plug-in: /usr/lib64/cinepaint/0.22-1/plug-ins/iol
plugin count = 53
/usr/lib64/cinepaint/0.22-1/plug-ins/clothify.py
/usr/lib64/cinepaint/0.22-1/plug-ins/sphere.py
Traceback (most recent call last):
  File "/usr/lib64/cinepaint/0.22-1/plug-ins/gimpcons.py", line 21, in <module>
    import gtkcons
  File "/usr/lib64/cinepaint/0.22-1/plug-ins/gtkcons.py", line 108, in <module>
    class Console(GtkVBox):
NameError: name 'GtkVBox' is not defined
wire_read: unexpected EOF (plug-in crashed?)
/usr/lib64/cinepaint/0.22-1/plug-ins/foggify.py
/usr/lib/python2.6/site-packages/abrt_exception_handler.py:114: GtkDeprecationWarning: gtk.TRUE is deprecated, use True instead
  text += "%s: %s\n" % (key, repr(val))
/usr/lib/python2.6/site-packages/abrt_exception_handler.py:114: GtkDeprecationWarning: gtk.FALSE is deprecated, use False instead
  text += "%s: %s\n" % (key, repr(val))
Traceback (most recent call last):
  File "/usr/lib64/cinepaint/0.22-1/plug-ins/gtkcons.py", line 108, in <module>
    class Console(GtkVBox):
NameError: name 'GtkVBox' is not defined
wire_read: unexpected EOF (plug-in crashed?)
/usr/lib64/cinepaint/0.22-1/plug-ins/whirlpinch.py
/usr/lib64/cinepaint/0.22-1/plug-ins/shadow_bevel.py
Traceback (most recent call last):
  File "/usr/lib64/cinepaint/0.22-1/plug-ins/pdbbrowse.py", line 31, in <module>
    class BrowseWin(gtk.GtkWindow):
AttributeError: 'module' object has no attribute 'GtkWindow'
wire_read: unexpected EOF (plug-in crashed?)
script-fu.c:115
/usr/lib64/cinepaint/0.22-1/plug-ins/script-fu
WARNING: /builddir/build/BUILD/oyranos-0.1.9/oyranos.c:253 oyGetPathFromProfileName_() profile not found in colour path: sRGB.icc[-1] 

lcms: Error #12288; cinepaint fatal error: sigsegv caught
cinepaint (pid:7509): [E]xit, [H]alt, show [S]tack trace or [P]roceed: S
#0  0x0000003a208a66be in waitpid () from /lib64/libc.so.6
#1  0x0000003a22017fd2 in g_on_error_stack_trace ()
#2  0x0000003a22018178 in g_on_error_query () from /lib64/libglib-2.0.so.0
#3  0x00000000004459f4 in ?? ()
#4  <signal handler called>
#5  0x0000003a20847fe7 in vfprintf () from /lib64/libc.so.6
#6  0x0000003a20849390 in buffered_vfprintf () from /lib64/libc.so.6
#7  0x0000003a208444fe in vfprintf () from /lib64/libc.so.6
#8  0x0000003a208f8fd7 in __vfprintf_chk () from /lib64/libc.so.6
#9  0x0000003a308082b7 in cmsSignalError () from /usr/lib64/liblcms.so.1
#10 0x0000003a3080e668 in _cmsCreateProfileFromFilePlaceholder ()
#11 0x0000003a30812009 in cmsOpenProfileFromFile ()
#12 0x0000000000433943 in ?? ()
#13 0x0000000000434428 in ?? ()
#14 0x000000000045980e in ?? ()
#15 0x00000000004da831 in ?? ()
#16 0x0000003a2300b98e in g_closure_invoke () from /lib64/libgobject-2.0.so.0
#17 0x0000003a2301f947 in ?? () from /lib64/libgobject-2.0.so.0
#18 0x0000003a23020de6 in g_signal_emit_valist ()
#19 0x0000003a230213a3 in g_signal_emit () from /lib64/libgobject-2.0.so.0
#20 0x00000039f8c8f665 in ?? () from /usr/lib64/libgtk-x11-2.0.so.0
#21 0x0000003a2300b98e in g_closure_invoke () from /lib64/libgobject-2.0.so.0
#22 0x0000003a2301f228 in ?? () from /lib64/libgobject-2.0.so.0
#23 0x0000003a23020de6 in g_signal_emit_valist ()
#24 0x0000003a230213a3 in g_signal_emit () from /lib64/libgobject-2.0.so.0
#25 0x00000039f8c8e007 in ?? () from /usr/lib64/libgtk-x11-2.0.so.0
#26 0x00000039f8d51003 in ?? () from /usr/lib64/libgtk-x11-2.0.so.0
#27 0x0000003a2300b98e in g_closure_invoke () from /lib64/libgobject-2.0.so.0
#28 0x0000003a2301f59c in ?? () from /lib64/libgobject-2.0.so.0
#29 0x0000003a23020c29 in g_signal_emit_valist ()
#30 0x0000003a230213a3 in g_signal_emit () from /lib64/libgobject-2.0.so.0
#31 0x00000039f8e8190f in ?? () from /usr/lib64/libgtk-x11-2.0.so.0
#32 0x00000039f8d47d63 in gtk_propagate_event ()
#33 0x00000039f8d48f2b in gtk_main_do_event ()
#34 0x00000039f886039c in ?? () from /usr/lib64/libgdk-x11-2.0.so.0
#35 0x0000003a2203bd02 in g_main_context_dispatch ()
#36 0x0000003a2203fae8 in ?? () from /lib64/libglib-2.0.so.0
#37 0x0000003a2203fff5 in g_main_loop_run () from /lib64/libglib-2.0.so.0
#38 0x00000039f8d493c7 in gtk_main () from /usr/lib64/libgtk-x11-2.0.so.0
#39 0x0000000000487e45 in ?? ()
#40 0x0000003a2081ec5d in __libc_start_main () from /lib64/libc.so.6
#41 0x0000000000417af9 in ?? ()
#42 0x00007fff2dc1bc28 in ?? ()
#43 0x000000000000001c in ?? ()
#44 0x0000000000000001 in ?? ()
#45 0x00007fff2dc1c5a2 in ?? ()
#46 0x0000000000000000 in ?? ()
cinepaint fatal error: sigsegv caught
cinepaint (pid:7509): [E]xit, [H]alt, show [S]tack trace or [P]roceed: E
Comment 1 Nicolas Chauvet (kwizart) 2011-02-22 03:33:35 EST
Short story:
-------------
Here are cinepaint updates, please give them test -  feedback is awaited:

https://admin.fedoraproject.org/updates/cinepaint-0.25.0-0.1.fc15
https://admin.fedoraproject.org/updates/cinepaint-0.25.0-0.1.fc14
https://admin.fedoraproject.org/updates/cinepaint-0.25.0-0.1.fc13

In a day or so , You should be able to do:
yum update --enablerepo=updates-testing cinepaint\*


Long Story:
----------
Cinepaint upstream hasn't seen a clear 'source code release' since a lot of time. So I couldn't have rebased on this release to provide an update for Fedora.
Instead, I've provided an pre-release snapshot of the 0.25 version which should fix most of the experienced bug.
I cannot triage every single abrt reports, so I will close the bugs to current release. But please reopen if you are abble to reproduce. I will try to get better care then.

Thx for your understanding and sorry for the lack of answer until now.

Note You need to log in before you can comment on or make changes to this bug.