Bug 612284 - /etc/sysconfig/network-scripts/ifup-ib: line 79: [: too many arguments
Summary: /etc/sysconfig/network-scripts/ifup-ib: line 79: [: too many arguments
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rdma   
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Doug Ledford
QA Contact: Gurhan Ozen
URL:
Whiteboard:
Keywords:
: 602941 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-07 18:49 UTC by Gurhan Ozen
Modified: 2013-11-04 02:00 UTC (History)
4 users (show)

Fixed In Version: rdma-1.0-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 21:28:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gurhan Ozen 2010-07-07 18:49:21 UTC
Description of problem:
# cat /etc/sysconfig/network-scripts/ifcfg-ib0 
DEVICE=ib0
TYPE=Infiniband
BOOTPROTO=static
BROADCAST=192.0.0.255
IPADDR=192.0.1.7
NETMASK=255.255.255.0
NETWORK=192.0.0.0
ONBOOT=yes
# ifup ib0
/etc/sysconfig/network-scripts/ifup-ib: line 79: [: too many arguments


Version-Release number of selected component (if applicable):
rdma-1.0-7.el6.noarch

How reproducible:
Everytime.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Doug Ledford 2010-07-09 17:24:53 UTC
Simple fix: use quoting for arguments or nest tests and only test if variable exists.  Either way, it's not hard to fix and should be done prior to GA.

Comment 3 Doug Ledford 2010-08-02 14:21:23 UTC
*** Bug 602941 has been marked as a duplicate of this bug. ***

Comment 4 Doug Ledford 2010-08-03 06:52:06 UTC
Changes made, will be tested tomorrow and checked in after successful tests.

Comment 6 Justin Clift 2010-08-10 06:28:04 UTC
As a data point, this looks good here.  rdma-1.0-8-el6 (recompiled for F13) solves the problem for my F13 desktop.

Comment 7 releng-rhel@redhat.com 2010-11-10 21:28:22 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.