Bug 612289 - kdump to network target fails over bridge device
Summary: kdump to network target fails over bridge device
Status: CLOSED DUPLICATE of bug 558733
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kexec-tools (Show other bugs)
(Show other bugs)
Version: 5.5
Hardware: All Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Cong Wang
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-07 19:00 UTC by Dave Maley
Modified: 2013-09-30 02:18 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-08 07:40:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
serial console log during kdump using scp (4.04 KB, text/plain)
2010-07-07 19:00 UTC, Dave Maley
no flags Details

Description Dave Maley 2010-07-07 19:00:40 UTC
Created attachment 430157 [details]
serial console log during kdump using scp

Description of problem: (effectively a rhel5.5 clone of bug 602325)
kdump to a network target (scp or nfs) fails over a bridge device.  The
messages below are output when restarting the kdump service:

   # service kdump restart
   Stopping kdump:                                            [  OK  ]
   Detected /etc/kdump.conf or /boot/vmlinuz-2.6.32-28.el6.x86_64 change
   Rebuilding /boot/initrd-2.6.32-28.el6.x86_64kdump.img
   ls: cannot access /sys/class/net/br0/device: No such file or directory
   Starting kdump:                                            [  OK  ]



Version-Release number of selected component (if applicable):
- kexec-tools-1.102pre-96.el5
- kernel-2.6.18-194.el5


How reproducible:
always


Steps to Reproduce:
1. create bridge device
2. configure kdump.conf to use scp or nfs
3. restart kdump service
4. panic the server

  
Actual results:
vmcore is not captured on remote host


Expected results:
vmcore captured on remote host


Additional info:

Comment 1 Dave Maley 2010-07-07 19:06:37 UTC
I've tested the proposed patch from bug 602325 however there are a couple problems I encountered.

First I had to add brctl as an extra_bin otherwise creation of br0 during kdump failed.

After adding that I'm seeing udhcpc failures, likely the same as noted in https://bugzilla.redhat.com/show_bug.cgi?id=602325#c1

On the same test system I'm able to successfully dump to a network target when no bridge device is configured.  The udhcpc failyres only occur when using a bridged device.

Comment 2 Cong Wang 2010-07-08 03:23:38 UTC
(In reply to comment #1)
> I've tested the proposed patch from bug 602325 however there are a couple
> problems I encountered.
> 
> First I had to add brctl as an extra_bin otherwise creation of br0 during kdump
> failed.
> 

Odd, I didn't meet this when I tested it.


> After adding that I'm seeing udhcpc failures, likely the same as noted in
> https://bugzilla.redhat.com/show_bug.cgi?id=602325#c1
> 
> On the same test system I'm able to successfully dump to a network target when
> no bridge device is configured.  The udhcpc failyres only occur when using a
> bridged device.    

Yeah, exactly. I am not sure if this is a problem of udhcpc or other things.

Comment 3 Cong Wang 2010-07-08 07:37:49 UTC
This is somewhat duplicated with Bug 558733.

Comment 4 Cong Wang 2010-07-08 07:40:43 UTC

*** This bug has been marked as a duplicate of bug 558733 ***


Note You need to log in before you can comment on or make changes to this bug.