Bug 612329 - [abrt] crash in firefox-3.6.4-1.fc13: Process /usr/lib/firefox-3.6/firefox was killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in firefox-3.6.4-1.fc13: Process /usr/lib/firefox-3.6/firefox wa...
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 13
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:4ac82b6aadb317800a79e50ceee...
Keywords:
: 612651 613038 613288 613494 614022 614085 614795 615440 615457 615551 616440 616657 616811 618468 619115 619969 621417 622073 622236 622984 624774 626847 626878 626930 627138 629618 643358 648890 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-07 21:48 UTC by Joe Zeff
Modified: 2011-01-26 21:09 UTC (History)
14 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-01-26 21:09:19 UTC


Attachments (Terms of Use)
File: backtrace (74.56 KB, text/plain)
2010-07-07 21:48 UTC, Joe Zeff
no flags Details

Description Joe Zeff 2010-07-07 21:48:39 UTC
abrt 1.1.1 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/lib/firefox-3.6/firefox
comment: Ever since today's Fedora 13 updates, including to Xorg (I logged out and back in after the updates.) Firefox has been crashing repeatedly.
component: firefox
executable: /usr/lib/firefox-3.6/firefox
global_uuid: 4ac82b6aadb317800a79e50ceee15784236e80bd
kernel: 2.6.33.5-124.fc13.i686
package: firefox-3.6.4-1.fc13
rating: 4
reason: Process /usr/lib/firefox-3.6/firefox was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

Comment 1 Joe Zeff 2010-07-07 21:48:42 UTC
Created attachment 430182 [details]
File: backtrace

Comment 2 Joe Zeff 2010-07-07 21:50:31 UTC
This started after the morning's set of Fedora updates, including to Xorg.  After the updates, I logged out and back in, so I'm using the "latest and greatest."  Firefox had been crashing repeatedly, with no clear pattern.

Comment 3 Mark Polo 2010-07-08 07:30:44 UTC
I have the same problem under x86_64. For me, the Firefox crash comes within a few seconds of startup, whether I load previous tabs or not. I have been forced to switch browsers at the moment.

Comment 4 Joe Zeff 2010-07-08 18:41:20 UTC
I don't know if this is significant, but I've found that if I tell Firefox to restore the crashed session, it generally selects a page from earlier in the browsing history, not the one I was on when it crashed.  If it crashes while loading a page, it sometimes picks the one I was leaving, but more often an earlier page.  And, once it's selected that page it goes there every time it crashes for the next several hours.

And, I might add, it's been known to crash while I've been reading a static page, straight html, with no dynamic content.  Don't know if this will help, but it does suggest that the page's content isn't an issue.

Also, if it helps, I'm using an nVidia card with the appropriate kmod-nvidia drivers from Fedora, and everything else works fine.

Comment 5 John Thacker 2010-07-11 04:03:40 UTC
I have this problem, and upon downgrading firefox and xulrunner with yum, it went away.  Any webpage that takes a while to load causes a crash.  I assume it's somehow related to the code to kill unresponsive plugins.

Comment 6 Joe Zeff 2010-07-11 04:37:43 UTC
I haven't tested it, yet, but it might be xulrunner that's the culpret.  Currently I'm using Seamonkey as a workaround and it's running a tad sluggish, especially in typing boxes.  I've also observed that complex pages bog it down, not only when loading, but when scrolling, almost to the point of locking up.  I won't have time to play with it until Monday at the earliest, but if anybody else who's having this issue tries downgrading xlrunner only I'd appreciate a report.

Comment 7 Mark Polo 2010-07-17 09:16:23 UTC
I downgraded both firefox and xulrunner, with continued crashing. (I will try a reboot shortly to see if that makes a difference.)

Comment 8 Karel Klíč 2010-11-09 14:40:53 UTC
*** Bug 612651 has been marked as a duplicate of this bug. ***

Comment 9 Karel Klíč 2010-11-09 14:40:58 UTC
*** Bug 613038 has been marked as a duplicate of this bug. ***

Comment 10 Karel Klíč 2010-11-09 14:41:04 UTC
*** Bug 613288 has been marked as a duplicate of this bug. ***

Comment 11 Karel Klíč 2010-11-09 14:41:08 UTC
*** Bug 613494 has been marked as a duplicate of this bug. ***

Comment 12 Karel Klíč 2010-11-09 14:41:13 UTC
*** Bug 614022 has been marked as a duplicate of this bug. ***

Comment 13 Karel Klíč 2010-11-09 14:41:18 UTC
*** Bug 614085 has been marked as a duplicate of this bug. ***

Comment 14 Karel Klíč 2010-11-09 14:41:23 UTC
*** Bug 614795 has been marked as a duplicate of this bug. ***

Comment 15 Karel Klíč 2010-11-09 14:41:28 UTC
*** Bug 615440 has been marked as a duplicate of this bug. ***

Comment 16 Karel Klíč 2010-11-09 14:41:34 UTC
*** Bug 615457 has been marked as a duplicate of this bug. ***

Comment 17 Karel Klíč 2010-11-09 14:41:39 UTC
*** Bug 615551 has been marked as a duplicate of this bug. ***

Comment 18 Karel Klíč 2010-11-09 14:41:44 UTC
*** Bug 616440 has been marked as a duplicate of this bug. ***

Comment 19 Karel Klíč 2010-11-09 14:41:49 UTC
*** Bug 616657 has been marked as a duplicate of this bug. ***

Comment 20 Karel Klíč 2010-11-09 14:41:53 UTC
*** Bug 616811 has been marked as a duplicate of this bug. ***

Comment 21 Karel Klíč 2010-11-09 14:41:58 UTC
*** Bug 618468 has been marked as a duplicate of this bug. ***

Comment 22 Karel Klíč 2010-11-09 14:42:03 UTC
*** Bug 619115 has been marked as a duplicate of this bug. ***

Comment 23 Karel Klíč 2010-11-09 14:42:07 UTC
*** Bug 619969 has been marked as a duplicate of this bug. ***

Comment 24 Karel Klíč 2010-11-09 14:42:12 UTC
*** Bug 621417 has been marked as a duplicate of this bug. ***

Comment 25 Karel Klíč 2010-11-09 14:42:17 UTC
*** Bug 622073 has been marked as a duplicate of this bug. ***

Comment 26 Karel Klíč 2010-11-09 14:42:22 UTC
*** Bug 622236 has been marked as a duplicate of this bug. ***

Comment 27 Karel Klíč 2010-11-09 14:42:26 UTC
*** Bug 622984 has been marked as a duplicate of this bug. ***

Comment 28 Karel Klíč 2010-11-09 14:42:32 UTC
*** Bug 624774 has been marked as a duplicate of this bug. ***

Comment 29 Karel Klíč 2010-11-09 14:42:37 UTC
*** Bug 626847 has been marked as a duplicate of this bug. ***

Comment 30 Karel Klíč 2010-11-09 14:42:41 UTC
*** Bug 626878 has been marked as a duplicate of this bug. ***

Comment 31 Karel Klíč 2010-11-09 14:42:48 UTC
*** Bug 626930 has been marked as a duplicate of this bug. ***

Comment 32 Karel Klíč 2010-11-09 14:42:52 UTC
*** Bug 627138 has been marked as a duplicate of this bug. ***

Comment 33 Karel Klíč 2010-11-09 14:42:57 UTC
*** Bug 629618 has been marked as a duplicate of this bug. ***

Comment 34 Karel Klíč 2010-11-09 14:43:02 UTC
*** Bug 643358 has been marked as a duplicate of this bug. ***

Comment 35 Karel Klíč 2010-11-09 14:43:07 UTC
*** Bug 648890 has been marked as a duplicate of this bug. ***

Comment 36 Chris Campbell 2011-01-26 19:59:28 UTC
Reporter, have you upgraded to Fedora 14, and/or continued to upgrade/update Firefox and xulrunner? If so, is this still an issue for you?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 37 Joe Zeff 2011-01-26 20:16:58 UTC
This bug stopped being an issue about six months ago, after I was able to update some of my addons.  It now appears that one of them was causing the trouble, but I've no idea which one.  I never updated the bug report because there was no sign that anybody was paying the slightest bit of attention to it.

Comment 38 Chris Campbell 2011-01-26 21:09:19 UTC
Yes, apologies for that. Thank you for your update.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers


Note You need to log in before you can comment on or make changes to this bug.