Bug 61233 - yphelper does not like Solaris servers.
Summary: yphelper does not like Solaris servers.
Status: CLOSED DUPLICATE of bug 26362
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ypserv (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-15 16:58 UTC by Mike Gahagan
Modified: 2007-04-18 16:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-19 15:57:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike Gahagan 2002-03-15 16:58:01 UTC
Description of Problem:

The yphelper program used by the ypinit script does not appear to work when
attempting to set up a slave NIS server to a Sun master NIS server

Version-Release number of selected component (if applicable):

1.3.12-2 on 7.2 w/ all current eratta installed

How Reproducible:

always

Steps to Reproduce:
1. Attempt to configure 7.2 to be a slave NIS server
2. 
3. 

Actual Results:

ypinit fails with 

Can't enumerate maps from <master server hostname>. Please check that is running

Expected Results:

Map transfer should have proceded without incident.

Additional Information:
	
In ypinit, there is a commented line above the yphelper line that uses ypwhich
-m filtering through grep/awk. uncommenting that line and commenting out the
yphelper line allowed the script to work properly, however this is prone to
failure if one isn't careful how they enter the hostname of the master NIS server.

Tests with yphelper by itself on the command line with the same options that the
script uses results in no output generated at all where the ypwhich -m /grep/awk
combination always returned the correct results.

Comment 1 Alexander Larsson 2002-03-21 15:49:19 UTC

*** This bug has been marked as a duplicate of 26362 ***


Note You need to log in before you can comment on or make changes to this bug.