Bug 612374 - [fix available] closing while search for text box open causes segfault
[fix available] closing while search for text box open causes segfault
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: openoffice.org (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: David Tardon
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-07 22:32 EDT by Tim Burke
Modified: 2010-11-10 16:16 EST (History)
3 users (show)

See Also:
Fixed In Version: openoffice.org-3.2.1-19.5.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 16:16:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix for that (1.28 KB, patch)
2010-07-13 09:06 EDT, David Tardon
no flags Details | Diff

  None (edit)
Description Tim Burke 2010-07-07 22:32:02 EDT
I saw a typo in a printed version of a presentation so I opened it up and used the search capability to look for the word. found it and corrected, then did file->save.  Now if I exit out of OOo via File->Exit it gets a segfault:

/usr/lib64/openoffice.org3/program/soffice: line 127:  3578 Segmentation fault      (core dumped) "$sd_prog/$sd_binary" "$@"

I tried it on a second document and got the same fault.

[burke@localhost rh-summit]$ rpm -qa | grep office
openoffice.org-brand-3.2.0-12.6.el6.x86_64
openoffice.org-pdfimport-3.2.0-12.6.el6.x86_64
openoffice.org-impress-3.2.0-12.6.el6.x86_64
openoffice.org-graphicfilter-3.2.0-12.6.el6.x86_64
openoffice.org-langpack-en-3.2.0-12.6.el6.x86_64
openoffice.org-ure-3.2.0-12.6.el6.x86_64
openoffice.org-presenter-screen-3.2.0-12.6.el6.x86_64
openoffice.org-writer-core-3.2.0-12.6.el6.x86_64
openoffice.org-draw-3.2.0-12.6.el6.x86_64
openoffice.org-impress-core-3.2.0-12.6.el6.x86_64
openoffice.org-math-core-3.2.0-12.6.el6.x86_64
openoffice.org-opensymbol-fonts-3.2.0-12.6.el6.noarch
openoffice.org-writer-3.2.0-12.6.el6.x86_64
openoffice.org-math-3.2.0-12.6.el6.x86_64
openoffice.org-calc-3.2.0-12.6.el6.x86_64
openoffice.org-calc-core-3.2.0-12.6.el6.x86_64
openoffice.org-xsltfilter-3.2.0-12.6.el6.x86_64
openoffice.org-core-3.2.0-12.6.el6.x86_64
openoffice.org-draw-core-3.2.0-12.6.el6.x86_64
[burke@localhost rh-summit]$
Comment 1 David Tardon 2010-07-08 01:25:19 EDT
Steps to reproduce:
1. create new presentation
2. Edit->Find and Replace
3. search for something, like 'a'; click off the msgbox reporting that the string was not found
4. File->Exit
5. crash

Seems to be OK in DEV300_m84.
Comment 2 David Tardon 2010-07-08 01:46:24 EDT
dtardon->tburke: I'm not sure this qualifies as a blocker:

1. It only happens if you leave the find dialog open.
2. It only happens on exit. It's not like you wanted to continue to use the app and it crashed on you :)
3. All files have been saved or discarded already, so there is no danger of data loss and no annoying recovery dialog on the next start.
Comment 3 Caolan McNamara 2010-07-08 03:57:13 EDT
Still, if we have an easy fix it's no skin off our nose to jam it in.
Comment 5 David Tardon 2010-07-13 09:06:10 EDT
Created attachment 431455 [details]
fix for that

The fix has been committed as a part of find toolbar implementation (changeset 7222222b05a3). Here is just the relevant part of the whole commit.
Comment 7 David Tardon 2010-07-13 10:32:28 EDT
building as openoffice.org-3.2.1-19.5.el6
Comment 9 Lubos Kocman 2010-08-02 03:14:46 EDT
Verified on openoffice.org-writer-3.2.1-19.5.el6
Comment 10 releng-rhel@redhat.com 2010-11-10 16:16:48 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.