Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 612440 - [abrt] abrt-gui-1.1.8-2.el6: CReporterAssistant.py:415:on_plugin_toggled:ValueError: list.remove(x): x not in list
[abrt] abrt-gui-1.1.8-2.el6: CReporterAssistant.py:415:on_plugin_toggled:Valu...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: abrt (Show other bugs)
6.0
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Jiri Moskovcak
Michal Nowak
abrt_hash:5d2431f9
:
: 612457 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-08 04:50 EDT by Michal Hlavinka
Modified: 2015-02-01 17:52 EST (History)
9 users (show)

See Also:
Fixed In Version: abrt-1.1.9-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 14:33:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (704 bytes, text/plain)
2010-07-08 04:50 EDT, Michal Hlavinka
no flags Details

  None (edit)
Description Michal Hlavinka 2010-07-08 04:50:16 EDT
abrt version: 1.1.8
architecture: x86_64
cmdline: /usr/bin/python /usr/share/abrt/CCMainWindow.py
comment: When doing the same thing second time, I was not able to reproduce this
component: abrt
executable: /usr/share/abrt/CCMainWindow.py
kernel: 2.6.32-43.el6.x86_64
package: abrt-gui-1.1.8-2.el6
rating: 4
reason: CReporterAssistant.py:415:on_plugin_toggled:ValueError: list.remove(x): x not in list
release: Red Hat Enterprise Linux Client release 6.0 Beta (Santiago)
time: 1278578375
uid: 500

backtrace
-----
CReporterAssistant.py:415:on_plugin_toggled:ValueError: list.remove(x): x not in list

Traceback (most recent call last):
  File "/usr/share/abrt/CReporterAssistant.py", line 415, in on_plugin_toggled
    self.selected_reporters.remove(reporter)
ValueError: list.remove(x): x not in list

Local variables in innermost frame:
complete: False
reporter: <ABRTPlugin.PluginInfo instance at 0x7fc7fb389050>
self: <CReporterAssistant.ReporterAssistant instance at 0x7fc7fdc7acb0>
plugin: <gtk.CheckButton object at 0x7fc7fdc8c9b0 (GtkCheckButton at 0x11d7ed0)>
plugins: [<gtk.CheckButton object at 0x7fc7fdc8c9b0 (GtkCheckButton at 0x11d7ed0)>]
page: <gtk.VBox object at 0x7fc7fdc8c460 (GtkVBox at 0x12f03b0)>

How to reproduce
-----
I've tried to report a bug
1) select bug
2) click report
now I got window with only bugzilla plugin which was already checked (logger was missing), forward button disabled
3) uncheck bugzilla
4) check bugzilla again
5) fill logging information
6) confirm
->exception
Comment 1 Michal Hlavinka 2010-07-08 04:50:19 EDT
Created attachment 430271 [details]
File: backtrace
Comment 3 Michal Hlavinka 2010-07-08 05:25:17 EDT
scratch step 5) and 6) from "how to reproduce", happened again now, just after rechecking bugzilla reporter
Comment 4 Michal Hlavinka 2010-07-08 05:34:24 EDT
and another note is that it happens only first time after abrtd (re)start
Comment 5 Michal Hlavinka 2010-07-08 05:54:30 EDT
Package: abrt-gui-1.1.8-2.el6
Architecture: x86_64
OS Release: Red Hat Enterprise Linux Client release 6.0 Beta (Santiago)


How to reproduce
-----
I've tried to report a bug
1) select bug
2) click report
now I got window with only bugzilla plugin which was already checked (logger was missing), forward button disabled
3) uncheck bugzilla
4) check bugzilla again
->exception


Comment
-----
trying to reproduce another abrt bug, sorry for noise
Comment 8 Karel Klíč 2010-07-14 05:42:26 EDT
I checked that this bug is fixed in the last build.
Comment 12 Karel Klíč 2010-07-14 12:15:37 EDT
*** Bug 612457 has been marked as a duplicate of this bug. ***
Comment 15 releng-rhel@redhat.com 2010-11-10 14:33:35 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.