Bug 612457 - problems with bugzilla configuration with missing gnome keyring and no other reporting plugin enabled
problems with bugzilla configuration with missing gnome keyring and no other ...
Status: CLOSED DUPLICATE of bug 612440
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: abrt (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Nikola Pajkovsky
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-08 05:38 EDT by Michal Hlavinka
Modified: 2014-02-02 17:14 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-14 12:15:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Hlavinka 2010-07-08 05:38:58 EDT
Description of problem:
there are hidden steps required to get bugzilla reporter plugin working when you have no other reporter plugin enabled and no gnome keyring, see steps to reproduce for more details

Version-Release number of selected component (if applicable):
# rpm -qa | grep abrt | sort
abrt-1.1.8-2.el6.x86_64
abrt-addon-ccpp-1.1.8-2.el6.x86_64
abrt-addon-kerneloops-1.1.8-2.el6.x86_64
abrt-addon-python-1.1.8-2.el6.x86_64
abrt-cli-1.1.8-2.el6.x86_64
abrt-debuginfo-1.1.8-2.el6.x86_64
abrt-desktop-1.1.8-2.el6.x86_64
abrt-gui-1.1.8-2.el6.x86_64
abrt-libs-1.1.8-2.el6.x86_64
abrt-plugin-bugzilla-1.1.8-2.el6.x86_64
abrt-plugin-logger-1.1.8-2.el6.x86_64
abrt-plugin-reportuploader-1.1.8-2.el6.x86_64
abrt-plugin-sosreport-1.1.8-2.el6.x86_64


How reproducible:
always


Steps to Reproduce:
prerequisites=no gnome keyring (for example run from KDE)
1.edit /etc/abrt/abrt.conf
CCpp = Bugzilla
2. service abrtd restart
3. try to report any crash in C program


Actual results:
you get reporter plugin selection window, only bugzilla plugin is listed and it's checked, but forward button is disabled (probably because of missing bugzilla login configuration). you need to uncheck bugzilla and check it again to get bugzilla login configuration window which is not very intuitive


Expected results:
a) bugzilla plugin unchecked
OR
b) bugzilla plugin checked and forward button enabled, ask for login information after forward button pressed
Comment 3 Karel Klíč 2010-07-14 12:15:37 EDT
This seems like a duplicate of #612440 to me. There was a bug in the GUI with the plugin checker, which is now fixed. AFAIK the gnome keyring availability does not affect plugin selection.

*** This bug has been marked as a duplicate of bug 612440 ***

Note You need to log in before you can comment on or make changes to this bug.