Bug 612459 - have to select user twice after rejecting timed login in gdm
have to select user twice after rejecting timed login in gdm
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gdm (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: jmccann
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-08 05:41 EDT by Vladimir Benes
Modified: 2015-01-14 18:25 EST (History)
4 users (show)

See Also:
Fixed In Version: gdm-2.30.4-7.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 15:28:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir Benes 2010-07-08 05:41:47 EDT
Description of problem:
after rejecting timed login in gdm I have to select user twice as after first attempt gdm goes back into user selection list

Version-Release number of selected component (if applicable):
gdm-2.30.4-5.el6.x86_64

How reproducible:


Steps to Reproduce:
1.enable timed login in custom.conf set time to approx 10 second to be able to reject it
2.go into gdm and reject timed login
3.select user
  
Actual results:
back in user selection list

Expected results:
password text field should be prompted 


Additional info:
Comment 2 Ray Strode [halfline] 2010-07-13 23:17:36 EDT
So i looked into this this evening, and it seems a lot more dire than comment 0.  I don't know if that's because gdm has been rev'd since that comment or if it's just a timing issue, but on my laptop timed login doesn't seem to work at all after cancel. It gets into a sort of deranged state where you can do anything anymore.

There were a few bugs that together made this happen.  I've corrected them and it should be better in gdm-2.30.4-7.el6.

marking MODIFIED and moving from exception to blocker given how much more serious the bug seems to be than I originally thought.
Comment 5 Radek Lat 2010-08-19 05:12:05 EDT
Tested and Verified on gdm-2.30.4-21.el6.x86_64, problem seems to be no longer present.
Comment 6 releng-rhel@redhat.com 2010-11-10 15:28:08 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.