Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 612481 - Enable migration subsections
Enable migration subsections
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.0
All Linux
high Severity high
: rc
: ---
Assigned To: Juan Quintela
Virtualization Bugs
:
: 613894 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-08 06:53 EDT by Juan Quintela
Modified: 2013-01-09 17:50 EST (History)
5 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.94.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 16:26:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juan Quintela 2010-07-08 06:53:44 EDT
Description of problem:

There is no way to add optional information to migration sections.  This means that any change in section format means that we are not able to migrate backwards inside rhel6.x.

This is the upstream solution (submitted) and previous discussions agreed with the design. This mechanism will allow us to be able to fix things later.

IDE was broken due to lack of subsections (it is not trivial to get that right).  I also have pushed this changes upstream.
Comment 3 Lawrence Lim 2010-07-08 21:44:40 EDT
Any suggestions on how we could verify the bug?
Comment 5 Dor Laor 2010-07-12 17:46:50 EDT
(In reply to comment #3)
> Any suggestions on how we could verify the bug?    

Basically, until no new development, in terms of functionality there is no change. This code adds some flexibility to the migration protocol so it will be able to ignore some subsections (that are not there yet).

The in flight IDE state was (re)implemented using this framework so it is worth to test that migration of IDE disks during load still works.
Comment 8 Amit Shah 2010-07-29 00:57:22 EDT
*** Bug 613894 has been marked as a duplicate of this bug. ***
Comment 9 Mike Cao 2010-07-29 02:02:38 EDT
Verified in qemu-kvm-0.12.1.2-2.97.el6

steps:
Migrate Guest with IDE disks with load via tcp protocol, unix protocol, compressed file,std file.

Actual Results:
After Migration, Guest still works.

The issues has already been fixed ,change status to VERIFIED.
Comment 10 releng-rhel@redhat.com 2010-11-10 16:26:26 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.