Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 612511 - SQLError during syncing
SQLError during syncing
Status: CLOSED DUPLICATE of bug 636561
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other (Show other bugs)
540
All Linux
high Severity medium
: ---
: ---
Assigned To: Michael Mráka
Red Hat Satellite QA List
: Regression
Depends On:
Blocks: 462714
  Show dependency treegraph
 
Reported: 2010-07-08 08:22 EDT by Petr Sklenar
Modified: 2010-09-23 18:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-23 18:03:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Sklenar 2010-07-08 08:22:10 EDT
Description of problem:
There is SQL error in the begging of syncing process

Version-Release number of selected component (if applicable):
spacewalk.nightly
spacewalk-backend-1.1.27-1.el5 on updated rhel5@x86_64

How reproducible:
always

Steps to Reproduce:
1. register spacewalk to hosted, rhn.r.c
2. start syncing rhel6 channel
  
Actual results:
[root@ultraman-1 rhn-activation]# satellite-sync -c rhel-x86_64-server-6-beta
12:09:13 Red Hat Network Satellite - live synchronization
12:09:13    url: https://satellite.rhn.redhat.com
12:09:13    debug/output level: 1
12:09:15    db:  spacewalk/<password>@XE
12:09:15
12:09:15 Retrieving / parsing channel-families data
12:09:19 channel-families data complete
12:09:22
12:09:22 Retrieving / parsing arches data
12:09:23 arches data complete
12:09:23
12:09:23 Retrieving / parsing additional arches data
12:09:24 additional arches data complete
12:09:24
12:09:24 Retrieving / parsing channel data
12:09:54    p = previously imported/synced channel
12:09:54    . = channel not yet imported/synced
12:09:54    base-channels:
12:09:54       p rhel-x86_64-server-6-beta                3607
12:09:54
12:09:55 Channel data complete
12:09:55
12:09:55 Retrieving / parsing blacklists data
12:09:56 blacklists data complete
12:09:56
12:09:56 Retrieving / parsing product names data
Exception reported from ultraman-1.lab.eng.brq.redhat.com
Time: Thu Jul  8 12:09:59 2010
Exception type server.rhnSQL.sql_base.SQLError

Exception Handler Information
Traceback (most recent call last):
  File "/usr/share/rhn/satellite_tools/xmlSource.py", line 130, in process
    self.__parser.parse(self.__stream)
  File "/usr/lib64/python2.4/site-packages/_xmlplus/sax/expatreader.py", line 109, in parse
    xmlreader.IncrementalParser.parse(self, source)
  File "/usr/lib64/python2.4/site-packages/_xmlplus/sax/xmlreader.py", line 123, in parse
    self.feed(buffer)
  File "/usr/lib64/python2.4/site-packages/_xmlplus/sax/expatreader.py", line 216, in feed
    self._parser.Parse(data, isFinal)
  File "/usr/lib64/python2.4/site-packages/_xmlplus/sax/expatreader.py", line 314, in end_element
    self._cont_handler.endElement(name)
  File "/usr/share/rhn/satellite_tools/xmlSource.py", line 219, in endElement
    self.__container.endElement(element)
  File "/usr/share/rhn/satellite_tools/xmlSource.py", line 827, in endElement
    self.endContainerCallback()
  File "/usr/share/rhn/satellite_tools/diskImportLib.py", line 156, in endContainerCallback
    importer.run()
  File "/usr/share/rhn/server/importlib/importLib.py", line 649, in run
    self.submit()
  File "/usr/share/rhn/server/importlib/productNamesImport.py", line 33, in submit
    self.backend.processProductNames(self.batch)
  File "/usr/share/rhn/server/importlib/backend.py", line 1167, in processProductNames
    product_name = channel['name'])
  File "/usr/share/rhn/server/rhnSQL/sql_base.py", line 168, in execute
    return apply(self._execute_wrapper, (self._execute, ) + p, kw)
  File "/usr/share/rhn/server/rhnSQL/driver_cx_Oracle.py", line 119, in _execute_wrapper
    raise apply(sql_base.SQLError, ret)
SQLError: (1, 'ORA-00001: unique constraint (SPACEWALK.RHN_PRODUCTNAME_NAME_UQ) violated\n', "insert into rhnProductName (id, label, name) values (sequence_nextval('rhn_productname_id_seq'), :product_label, :product_name)")

12:10:05 *** SYSTEM INTERRUPT CALLED ***
12:10:05
12:10:05 Retrieving short package metadata (used for indexing)
12:10:05    Retrieving / parsing short package metadata: rhel-x86_64-server-6-beta (3607)
12:10:13 Diffing package metadata (what's missing locally?): rhel-x86_64-server-6-beta
            ________________________________________
Diffing:    ######################################## - complete
12:10:18
12:10:18 Downloading package metadata
12:10:19    Retrieving / parsing *relevant* package metadata: rhel-x86_64-server-6-beta (NONE RELEVANT)
12:10:20
12:10:20 Downloading rpm packages
12:10:20    Fetching any missing RPMs: rhel-x86_64-server-6-beta (3607)
12:11:31     1773/3607 Fetch successful: x3270-3.3.6-10.el6.2.x86_64.rpm (137888 bytes)
12:11:32     1774/3607 Fetch successful: kdelibs-experimental-4.3.4-3.el6.i686.rpm (34032 bytes)
12:11:34     1775/3607 Fetch successful: lzo-2.03-3.1.el6.x86_64.rpm (56564 bytes)
12:11:37     1776/3607 Fetch successful: evolution-data-server-doc-2.28.3-4.el6.noarch.rpm (560652 bytes)
12:11:39     1777/3607 Fetch successful: plymouth-graphics-libs-0.8.3-3.el6.i686.rpm (37740 bytes)
12:11:40     1778/3607 Fetch successful: opensm-libs-3.3.5-1.el6.x86_64.rpm (53768 bytes)
12:11:42     1779/3607 Fetch successful: acpid-1.0.10-2.1.el6.x86_64.rpm (37216 bytes)
12:11:44     1780/3607 Fetch successful: libXxf86vm-1.1.0-1.el6.i686.rpm (18780 bytes)
.....
process seems working
....

Expected results:
no traceback, no sql error 

Additional info:
Comment 7 Michael Mráka 2010-09-23 18:03:51 EDT

*** This bug has been marked as a duplicate of bug 636561 ***

Note You need to log in before you can comment on or make changes to this bug.