Bug 612515 - publican package fails because of missing images/icon.svg
publican package fails because of missing images/icon.svg
Status: CLOSED ERRATA
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
low Severity low
: ---
: ---
Assigned To: Jeff Fearn
Fedora Extras Quality Assurance
:
: 630497 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-08 08:29 EDT by Ruediger Landmann
Modified: 2010-11-23 23:17 EST (History)
5 users (show)

See Also:
Fixed In Version: publican-2.2-0.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-08 16:41:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ruediger Landmann 2010-07-08 08:29:36 EDT
Description of problem:
Building a binary package fails. Publican complains that images/icon.svg is missing, even if the book XML directory contains a file named images/icon.svg

Version-Release number of selected component (if applicable):
2.1

How reproducible:
100%

Steps to Reproduce:
1. run "publican package --binary" on a book that contains an images/icon.svg file in its XML directory

Actual results:
Packaging fails with an error like:

+ cp images/icon.svg /home/XXXXXX/rpmbuild/BUILDROOT/NAME_OF_BOOK/usr/share/icons/hicolor/scalable/apps/NAME_OF_BOOK.svg
cp: cannot stat `images/icon.svg': No such file or directory
error: Bad exit status from /var/tmp/rpm-tmp.tyJmfc (%install)

Expected results:
Packaging succeeds
Comment 1 Jeff Fearn 2010-07-08 20:41:47 EDT
A directory isn't being created in the %install section of the generated spec file when building with old style icons.

Fixed in build: 2.1-0.t1

Workaround: copy $lang/images/icon.svg to $lang/icons/icon.svg
Comment 2 Ruediger Landmann 2010-08-05 23:57:02 EDT
Verified in 2.1.t20

publican package --binary --lang en-US

on a book with only an en-US/images/icon.svg file. 

Packaging succeeded, and icon.svg was placed in /usr/share/icons/hicolor/scalable/apps/ in the binary RPM package.
Comment 3 Ruediger Landmann 2010-09-05 22:28:50 EDT
*** Bug 630497 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2010-10-06 01:48:09 EDT
publican-2.2-0.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/publican-2.2-0.fc13
Comment 5 Fedora Update System 2010-10-06 01:49:27 EDT
publican-2.2-0.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/publican-2.2-0.fc12
Comment 6 Fedora Update System 2010-10-06 01:49:30 EDT
publican-2.2-0.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/publican-2.2-0.fc14
Comment 7 Fedora Update System 2010-10-08 16:39:32 EDT
publican-2.2-0.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.