Bug 612555 - Port git-gui to hunspell
Port git-gui to hunspell
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: git (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: pstodulk
qe-baseos-daemons
: Reopened
Depends On:
Blocks: 645519 802730 840699
  Show dependency treegraph
 
Reported: 2010-07-08 10:11 EDT by Marc Milgram
Modified: 2015-03-03 08:51 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 802730 (view as bug list)
Environment:
Last Closed: 2015-03-03 08:51:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
concept patch (3.71 KB, patch)
2011-07-29 09:48 EDT, ritz
no flags Details | Diff

  None (edit)
Description Marc Milgram 2010-07-08 10:11:21 EDT
Description of problem:
git-gui complains:
  Spell checking is unavailable:

  No word lists can be found for the language "en_us".

Version-Release number of selected component (if applicable):
git-gui-1.7.1-1.el6.noarch


How reproducible:
100%

Steps to Reproduce:
1.run: git gui
  
Actual results:
At startup, git-gui complains that spell checking is unavailable.

Expected results:
No complaints, and spell checking works.

Additional info:
$ echo $LANG 
en_US.UTF-8
Comment 1 Bill Nottingham 2010-07-08 11:51:19 EDT
Changing summary to reflect what needs done.
Comment 2 Michael Cronenworth 2010-08-23 09:42:43 EDT
All you need to do is make sure "aspell" and "aspell-en" are installed. Spell checking will work fine without needing to port to hunspell or do anything else that drastic.
Comment 3 Bill Nottingham 2010-08-23 11:47:56 EDT
The point is, if the rest of the system is using hunspell, there's no point to shipping a separate spellchecking system just for git.
Comment 4 Adam Tkac 2010-08-24 04:04:26 EDT
(In reply to comment #3)
> The point is, if the rest of the system is using hunspell, there's no point to
> shipping a separate spellchecking system just for git.

Exactly. And another issue is that "aspell-en" package is not part of RHEL6.
Comment 5 Michael Cronenworth 2010-08-24 16:45:04 EDT
Sorry for the intrusion. I was looking at my RHEL5 system at the time, which still has aspell/aspell-en.
Comment 8 Suzanne Yeghiayan 2011-02-15 16:39:48 EST
This issue was proposed for RHEL 6.1 FasTrack but did not get resolved in time.
It has been moved to RHEL 6.2 FasTrack.
Comment 10 Suzanne Yeghiayan 2011-02-15 17:03:21 EST
This issue was proposed for RHEL 6.1 FasTrack but did not get resolved in time.
It has been moved to RHEL 6.2 FasTrack.
Comment 14 Adam Tkac 2011-07-28 09:49:13 EDT
After further inspection porting git-gui to hunspell is not possible because hunspell doesn't support some functions which are provided by aspell, notably listing of available dictionaries in scripting-friendly manner. Without this function git-gui GUI will be broken.

In my opinion optimal solution is to install proper aspell-* dictionary from EPEL. Another "solution" is to remove aspell package and git-gui won't complain that spell checker is missing.

Closing as wontfix.
Comment 20 ritz 2011-07-29 09:48:23 EDT
Created attachment 515888 [details]
concept patch

This looks like a hack to me, but allows git-gui to use hunspell. Works fine for me. The only caveat, the default lang is not set due to hunspell missing "$$cr master" option, but instead is picked by hunspell from env. This may break your system or life.
Comment 21 Adam Tkac 2011-08-02 07:37:32 EDT
(In reply to comment #20)
> Created attachment 515888 [details]
> concept patch
> 
> This looks like a hack to me, but allows git-gui to use hunspell. Works fine
> for me. The only caveat, the default lang is not set due to hunspell missing
> "$$cr master" option, but instead is picked by hunspell from env. This may
> break your system or life.

This seems like a good starting point for me, thanks for the patch. I will polish it a little and send it to upstream.
Comment 28 RHEL Product and Program Management 2013-10-13 21:18:59 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 29 pstodulk 2015-03-03 08:51:43 EST
Feel free to reopen when we get enough of a justification for this.

Note You need to log in before you can comment on or make changes to this bug.