Bug 612614 - There is warning about missing DB_CONFIG after /etc/init.d/slapd restart
Summary: There is warning about missing DB_CONFIG after /etc/init.d/slapd restart
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: openldap (Show other bugs)
(Show other bugs)
Version: 13
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Jan Vcelak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-08 15:45 UTC by Jaroslav Škarvada
Modified: 2013-03-04 01:27 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-20 18:11:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jaroslav Škarvada 2010-07-08 15:45:32 UTC
Description of problem:
There is warning about missing DB_CONFIG after /etc/init.d/slapd restart:

Checking configuration files for slapd:                    [WARNING]
bdb_db_open: warning - no DB_CONFIG file found in directory /var/lib/ldap: (2).
Expect poor performance for suffix "dc=my-domain,dc=com".

Version-Release number of selected component (if applicable):
openldap-servers-2.4.21-4.fc13

How reproducible:
Always

Steps to Reproduce:
1. /etc/init.d/slapd start
2. /etc/init.d/slapd restart
  
Actual results:
There is warning about missing DB_CONFIG.

Expected results:
There should be no warning.

Additional info:
mv /usr/share/doc/openldap-servers-2.4.21/DB_CONFIG.example /var/lib/ldap/DB_CONFIG
solved this for me.

Comment 1 Jan Vcelak 2010-07-20 18:11:11 UTC
The database is generated during the first startup of slapd. This is the reason why DB_CONFIG.example is shipped separately.

The server will run even if there is no DB_CONFIG file, probably with slight performance issues. The warning should attract database administrator to add this file into the database directory. Exactly the same way you did, seems it works ;-). This config file should be tuned anyway.

After a brief discussion, we agreed that this is not a bug.

(As it is possible to install the package with '--excludedocs' option, DB_CONFIG.example file will be placed in /usr/share/openldap-servers since openldap-2.4.21-10.fc13 and openldap-2.4.22-6.fc14.)


Note You need to log in before you can comment on or make changes to this bug.