Bug 612623 - condor_trigger_config does not cleanly close session
Summary: condor_trigger_config does not cleanly close session
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: condor   
(Show other bugs)
Version: Development
Hardware: All
OS: Linux
medium
medium
Target Milestone: 1.3
: ---
Assignee: Matthew Farrellee
QA Contact: Luigi Toscano
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-08 15:55 UTC by Matthew Farrellee
Modified: 2010-10-20 11:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-20 11:33:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matthew Farrellee 2010-07-08 15:55:42 UTC
Version-Release number of selected component (if applicable):

condor-qmf-7.4.4-0.4.el5


How reproducible:

non-deterministic


Steps to Reproduce:
1. with or without a triggerd running
2. run condor_triggerd_config

  
Actual results:

[root@mrg31 ~]# condor_trigger_config -l mrg31
Connecting to broker 'mrg31'...
Listing currently installed triggers...
No triggers currently installed
[root@mrg31 ~]# condor_trigger_config -l mrg31
Connecting to broker 'mrg31'...
Listing currently installed triggers...
No triggers currently installed
Exception in thread Thread for broker: mrg31:5672 (most likely raised during interpreter shutdown):
Traceback (most recent call last):
  File "/usr/lib64/python2.4/threading.py", line 442, in __bootstrap
  File "/usr/lib/python2.4/site-packages/qmf/console.py", line 2539, in run
  File "/usr/lib64/python2.4/Queue.py", line 125, in get
exceptions.TypeError: 'NoneType' object is not callable
Unhandled exception in thread started by 
Error in sys.excepthook:

Original exception was:
[root@mrg31 ~]# condor_trigger_config -l mrg31
Connecting to broker 'mrg31'...
Listing currently installed triggers...
No triggers currently installed
[root@mrg31 ~]# condor_trigger_config -l mrg31
Connecting to broker 'mrg31'...
Listing currently installed triggers...
No triggers currently installed
Exception in thread Thread for broker: mrg31:5672 (most likely raised during interpreter shutdown):
Traceback (most recent call last):
  File "/usr/lib64/python2.4/threading.py", line 442, in __bootstrap
  File "/usr/lib/python2.4/site-packages/qmf/console.py", line 2539, in run
  File "/usr/lib64/python2.4/Queue.py", line 125, in get
exceptions.TypeError: 'NoneType' object is not callable
Unhandled exception in thread started by 
Error in sys.excepthook:

Original exception was:
[root@mrg31 ~]# condor_trigger_config -l mrg31
Connecting to broker 'mrg31'...
Listing currently installed triggers...
No triggers currently installed
Exception in thread Thread for broker: mrg31:5672 (most likely raised during interpreter shutdown):
Traceback (most recent call last):
  File "/usr/lib64/python2.4/threading.py", line 442, in __bootstrap
  File "/usr/lib/python2.4/site-packages/qmf/console.py", line 2539, in run
  File "/usr/lib64/python2.4/Queue.py", line 125, in get
exceptions.TypeError: 'NoneType' object is not callable
Unhandled exception in thread started by 
Error in sys.excepthook:

Original exception was:
[root@mrg31 ~]# condor_trigger_config -l mrg31
Connecting to broker 'mrg31'...
Listing currently installed triggers...
No triggers currently installed
Exception in thread Thread for broker: mrg31:5672 (most likely raised during interpreter shutdown):
Traceback (most recent call last):
  File "/usr/lib64/python2.4/threading.py", line 442, in __bootstrap
  File "/usr/lib/python2.4/site-packages/qmf/console.py", line 2539, in run
  File "/usr/lib64/python2.4/Queue.py", line 125, in get
exceptions.TypeError: 'NoneType' object is not callable
[root@mrg31 ~]# condor_trigger_config -l mrg31
Connecting to broker 'mrg31'...
Listing currently installed triggers...
No triggers currently installed


Expected results:

100% return without the TypeError

Comment 1 Matthew Farrellee 2010-07-08 16:04:59 UTC
$ repeat 30
python condor_trigger_config.py -l mrg31
==> no threading TypeErrors

when session.delBroker is called before sys.exit

Comment 2 Matthew Farrellee 2010-07-08 16:32:04 UTC
Built in 7.4.4-0.5

Comment 3 Luigi Toscano 2010-09-01 16:44:18 UTC
The issue is not reproducible anymore.

Tested on RHEL4.8/5.5, i386/x86_64, moving to VERIFIED.
condor-7.4.4-0.9
condor-qmf-7.4.4-0.9
python-qmf-0.7.946106-8
python-qpid-0.7.946106-12
qmf-0.7.946106-12
qpid-cpp-server-0.7.946106-12
qpid-cpp-client-0.7.946106-12


Note You need to log in before you can comment on or make changes to this bug.