Bug 612640 - QMF: set configurable default of persistent for all grid objects
Summary: QMF: set configurable default of persistent for all grid objects
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: condor   
(Show other bugs)
Version: beta
Hardware: All Linux
low
high
Target Milestone: 1.3
: ---
Assignee: Pete MacKinnon
QA Contact: Tomas Rusnak
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-08 16:43 UTC by Pete MacKinnon
Modified: 2010-08-26 14:48 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-26 14:48:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pete MacKinnon 2010-07-08 16:43:59 UTC
We will make all the QMF objects transient by default except for the collector object. In that case the grid admin would have to explicitly configure QMF_IS_TRANSIENT=True for that object. Objects will have consistent IDs across restarts (i.e., a restarted mrg27 collector object will re-appear to cumin as the same mrg27 object).

This will be subject to further testing and review by cumin team.

Comment 1 Pete MacKinnon 2010-07-14 21:24:37 UTC
Flip-flop...

FH sha 184ef3ee1cc

Now all grid objects are persistent by default unless QMF_IS_PERSISTENT=false. However, this config var is still a little coarse-grained since some plugins manage multiple objects.

Comment 2 Tomas Rusnak 2010-08-25 13:04:48 UTC
Please, could you specify detailed steps how to reproduce this? To verify this, I also need package versions where the problem occurred and where was fixed.

Comment 3 Pete MacKinnon 2010-08-26 14:48:56 UTC
This change was implemented to support cumin's object ageing strategy. Difficult to test with qpid-tool due to its "sticky" nature. Not a issue at this time unless we hear otherwise from Justin.


Note You need to log in before you can comment on or make changes to this bug.