Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 612676 - virt-manager: advertise CDROM URL installs
virt-manager: advertise CDROM URL installs
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager (Show other bugs)
5.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-08 14:36 EDT by Issue Tracker
Modified: 2011-01-13 18:07 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
URL installation options for fully virtualized guests have been enabled in Virtual Machine Manager. This is accomplished by fetching a boot.iso disc image from the URL install tree.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-13 18:07:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Advertise FV CDROM URL installs (6.95 KB, text/plain)
2010-08-31 11:39 EDT, Cole Robinson
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0077 normal SHIPPED_LIVE virt-manager bug fix update 2011-01-12 12:21:58 EST

  None (edit)
Description Issue Tracker 2010-07-08 14:36:41 EDT
Escalated to Bugzilla from IssueTracker
Comment 5 Paolo Bonzini 2010-08-04 12:44:40 EDT
Cole, is the request to provide kernel/initrd/cmdline parameters for Xen fully-virtualized guests?
Comment 6 Cole Robinson 2010-08-04 12:56:40 EDT
Yes, I think that's what it boils down too.
Comment 8 Andrew Jones 2010-08-05 03:10:08 EDT
How is this related to passing cmdline parameters? To me it looks like the customer would just like to be able to select a URL for HVM installs from virt-manager (which is a currently grayed out option), rather than install from a locally stored ISO or using PXE (which are not grayed out). As they say correctly, this is already possible with virt-install because when you specify the URL, it goes out and fetches the boot.iso (so it will be temporarily local), and then it does a local iso install.

I realize that also supporting cmdline parameters would even further improve the flexibility of installs (such as giving anaconda a kickstart), but that doesn't seem to be the request here. They just want the same functionality with virt-manager as they already have with virt-install (virt-install doesn't support cmdline parameters for xen hvm guests either).

I could be completely missing something though; so if so, please clarify.

Drew
Comment 10 Andrew Jones 2010-08-05 09:48:39 EDT
I'm kicking this one back to virt-manager. I don't see any good reason to support the 'fetch boot.iso by url' concept in virt-install, but not in virt-manager.
Comment 11 Paolo Bonzini 2010-08-05 10:42:52 EDT
I think it's not that simple, "fetch boot.iso by URL" as currently implemented in virt-install still cannot include a kickstart file, nor specify the location for install.img and the packages, right?

The solution could be to download the kernel and initrd, and place them on a _custom_ ISO together with an appropriate isolinux configuration file.

I agree with Andrew however: this needs to be implemented in virt-install/virt-manager, not in xen, because it is a workaround that is specific to the installation scenario, and cannot be used in general.
Comment 12 Daniel Berrange 2010-08-05 10:54:32 EDT
Building custom ISOs is a waste of time. If someone wants to use kernel args, then boot the guest straight off a kernel+initrd instad of using an ISO. This is why I added support for kernel+initrd booting with Xen HVM upstream.
Comment 13 Andrew Jones 2010-08-05 11:08:09 EDT
(In reply to comment #11)
> I think it's not that simple, "fetch boot.iso by URL" as currently implemented
> in virt-install still cannot include a kickstart file, nor specify the location
> for install.img and the packages, right?

Right, and I acknowledged this in my initial comment, but the customer didn't mention _anything_ about this in their RFE, and in fact said "virt-install works". So we just need to mimic the behavior they like in virt-install in virt-manager, and it's a done deal. A note above the virt-manager URL option saying that it's going to grab "a minimal boot ISO image" from the given URL should be sufficient for clarity about what it's going to do. I got the "a minimal boot ISO image" verbiage from the virt-install man page.
Comment 14 Cole Robinson 2010-08-05 11:32:58 EDT
I think we need to hear from the customer. When they say 'virt-install has the option', have they actually verified this works? If so, what are they doing here:

virt-install --cdrom http://foo/bar...

or

virt-install --location http://foo/bar...

The former pulls down a boot.iso from the tree, and I think should already work in virt-manager: just enter the install tree URL in the local ISO text field. The UI could make this more explicit.

The latter pulls down kernel/initrd, and can acknowledge --extra-args option for use of kickstarts, etc. Upstream xen supports this, but I believe it has been technically rejected for RHEL5 given the risk of backporting the change.

So, what behavior is the customer looking for here?
Comment 15 Andrew Jones 2010-08-05 11:54:56 EDT
Cole,

Actually both those virt-install options do the same thing for Xen HVM guests. From the virt-install code

    # RHEL HACK: Restore previous behavior for xen HVM installs, where
    # --location == --cdrom for URLs
    if ishvm and virtinst.util.get_uri_driver(guest.conn.getURI()) == "xen":
        guest.installer.cdrom = True
Comment 16 Andrew Jones 2010-08-06 02:03:58 EDT
Cole pointed out that a URL can be put in the ISO text field of virt-manager already. Possibly the customer doesn't know that (I didn't). Maybe just passing this information on to the customer will be sufficient to satisfy their needs.
Comment 17 Michal Novotny 2010-08-06 06:39:16 EDT
(In reply to comment #16)
> Cole pointed out that a URL can be put in the ISO text field of virt-manager
> already. Possibly the customer doesn't know that (I didn't). Maybe just passing
> this information on to the customer will be sufficient to satisfy their needs.    

Well, for URL install of HVM guest instead of selecting the ISO image I gave the URL location there, i.e. something like http://server/install/x86_64/os/ and it automatically downloaded the boot.iso image from images/boot.iso of the tree. When I selected the install option of the guest the guest was asking for the installation source, i.e. CD-ROM, hard-drive or exported NFS/HTTP. In the virt-manager the CD-ROM mounted was /var/lib/xen/virtinst-boot.iso.XXXXXX where XXXXXX seems to be random characters available for path like used in mkstemp() function for C language so basically virtinst downloads the boot.iso file automatically for the used when URL is being entered (instead of ISO) so basically we should document that for URL install for HVM guests is possible since it seems that virtinst downloads the boot.iso image itself.

Michal
Comment 18 Cole Robinson 2010-08-06 11:41:08 EDT
Andrew, huh, I forgot about that hack. So yeah, I guess this is just about advertising in virt-manager that we can pull a boot.iso from a URL, and verifying that it works.
Comment 19 Cole Robinson 2010-08-31 11:39:07 EDT
Created attachment 442222 [details]
Advertise FV CDROM URL installs

We now enable the URL install options for FV guests, but disable the kernel/kickstart options and show a warning explaining that they don't work for Xen FV.
Comment 20 Cole Robinson 2010-09-14 16:16:24 EDT
Fixed in virt-manager-0.6.1-13.el5
Comment 22 yanbing du 2010-09-21 04:11:24 EDT
On host rhel5u5.
#rpm -q virt-manager
virt-manager-0.6.1-13.el5

The network installation option of virt-manager can be selected, and guest can be installed well.
Comment 23 Wayne Sun 2010-10-12 03:41:58 EDT
Verified on RHEL5u6
Build:20100930.0
pkg:
virt-manager-0.6.1-13.el5
kernel-2.6.18-225.el5
Comment 24 Jaromir Hradilek 2010-11-19 11:49:54 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
URL installation options for fully virtualized guests have been enabled in Virtual Machine Manager. This is accomplished by fetching a boot.iso disc image from the URL install tree.
Comment 26 errata-xmlrpc 2011-01-13 18:07:17 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0077.html

Note You need to log in before you can comment on or make changes to this bug.