Bug 612702 - system-config-netboot and pxeos PXEBOOTDIR cannot be changed [NEEDINFO]
Summary: system-config-netboot and pxeos PXEBOOTDIR cannot be changed
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-netboot   
(Show other bugs)
Version: 5.2
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Jaroslav Reznik
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-08 19:52 UTC by Richard BLANCHET
Modified: 2014-06-02 13:19 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 13:19:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (bugzilla.redhat.com)


Attachments (Terms of Use)

Description Richard BLANCHET 2010-07-08 19:52:08 UTC
Description of problem:
  I tried to set a specific PXEBOOTDIR using /etc/sysconfig/system-config-netboot config file.
  Still /tftpboot/linux-install/ is hardcoded to /tftpboot/linux-install/ in package install scripts and in Python script /usr/share/system-config-netboot/netboot_util.py.
  So when trying to run pxeos using an other PXEBOOTDIR value we still get PXE install kit created under /tftpboot/linux-install/.
nota: I ran command: pxeos -a -p FTP -D0 -s 10.13.16.1 -L /pub/rhel-5.2/tree -K ftp://10.13.16.1/pub/rhel-5.2/kickstart/ks.cfg RHEL-5.2_X86-64-test


Version-Release number of selected component (if applicable):
  system-config-netboot-cmd.noarch 0.1.45.1-1.el5


How reproducible: always


Steps to Reproduce:
1. install install system-config-netboot-cmd.noarch
2. change PXEBOOTDIR value in /etc/sysconfig/system-config-netboot config file
3. run pxeos and everything is still created under /tftpboot/linux-install/ instead of chosen PXEBOOTDIR value.

  
Actual results:

   everything is still created by pxeos under /tftpboot/linux-install/


Expected results:

   everything created by pxeos under chosen PXEBOOTDIR value set into /etc/sysconfig/system-config-netboot config file.


Additional info:

  Investigating the package files I found /usr/share/system-config-netboot/netboot_util.py where PXEBOOTDIR and PXECFGDIR seems to be incorrectly defined and set.
I fixed it as follow:

[root@my_redhat_server ~]# diff /usr/share/system-config-netboot/netboot_util.py my_patched_netboot_util.py
11d10
< PXECFGDIR=PXEBOOTDIR+"pxelinux.cfg/"
41a41
>     global PXEBOOTDIR
56a57
> PXECFGDIR=PXEBOOTDIR+"pxelinux.cfg/"

Still I get this error message:

# pxeos -a -p FTP -D0 -s 10.23.66.1 -L /pub/rhel-5.2/tree -K ftp://10.23.66.1/pub/rhel-5.2/kickstart/ks.cfg RHEL-5.2_X86-64-test
Traceback (most recent call last):
  File "/usr/sbin/pxeos", line 603, in ?
    pxeoslist.saveOSList(pxelist)
  File "/usr/sbin/pxeos", line 106, in saveOSList
    bootFD=open("%s/msgs/boot.msg" % PXEBOOTDIR,"w")
IOError: [Errno 2] No such file or directory: '/var/services/tftp-root/linux-install-test//msgs/boot.msg'

Therefore I manually moved needed PXE stuff directories to my tagerted PXEDIR:
# mv  /tftpboot/linux-install/* /var/services/tftp-root/linux-install/

And finaly pxeos runs smoothly setting up the PXE stuff where I want.

Therefore it looks to me like to issues to get fixed but I am not a developper.

Comment 1 RHEL Product and Program Management 2011-05-31 14:30:07 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 2 RHEL Product and Program Management 2012-06-12 01:05:20 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 3 RHEL Product and Program Management 2014-03-07 12:49:31 UTC
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.

Comment 4 RHEL Product and Program Management 2014-06-02 13:19:22 UTC
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).


Note You need to log in before you can comment on or make changes to this bug.