Bug 612794 - iphone tethering not working
iphone tethering not working
Status: CLOSED DUPLICATE of bug 577289
Product: Fedora
Classification: Fedora
Component: bluez (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-08 23:29 EDT by David Joo
Modified: 2011-05-04 10:54 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-04 10:54:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Joo 2010-07-08 23:29:39 EDT
Description of problem:
After package updates, uphone's tethering is not working.
Unfortunately can't pin point wehter it is bluez issues or dbug issue

Version-Release number of selected component (if applicable):
Fedora 13
bluez-4.64-1.fc13.x86_64
bluez-libs-4.64-1.fc13.x86_64
dbus-1.2.24-1.fc13.x86_64
dbus-libs-1.2.24-1.fc13.x86_64

How reproducible:
Just try to use iphone tethering


Steps to Reproduce:
1. update the system to the latest
2. turn on the bluetooth in the laptop
3. try to connect iphone through bluetooth and use it as a network accesspoint
4. Fails with below /var/log/messages entry
  
Actual results:
tethering not working

/var/log/messages
-------
Jul  9 13:08:08 djoo NetworkManager[1233]: <warn> (00:26:B0:D0:4F:AE): failed to look up interface index
Jul  9 13:08:08 djoo NetworkManager[1233]: <info> BT device DeVO's iPhone (00:26:B0:D0:4F:AE) added (NAP)
Jul  9 13:08:08 djoo NetworkManager[1233]: <info> (00:26:B0:D0:4F:AE): new Bluetooth device (driver: 'bluez' ifindex: -1)
Jul  9 13:08:08 djoo NetworkManager[1233]: <info> (00:26:B0:D0:4F:AE): exported as /org/freedesktop/NetworkManager/Devices/3
Jul  9 13:08:08 djoo NetworkManager[1233]: <info> (00:26:B0:D0:4F:AE): now managed
Jul  9 13:08:08 djoo NetworkManager[1233]: <info> (00:26:B0:D0:4F:AE): device state change: 1 -> 2 (reason 2)
Jul  9 13:08:08 djoo NetworkManager[1233]: <info> (00:26:B0:D0:4F:AE): deactivating device (reason: 2).
Jul  9 13:08:08 djoo NetworkManager[1233]: <info> (00:26:B0:D0:4F:AE): device state change: 2 -> 3 (reason 0)
Jul  9 13:08:08 djoo NetworkManager[1233]: <info> Activation (00:26:B0:D0:4F:AE) starting connection 'Network Access Point on DeVO's iPhone'
Jul  9 13:08:08 djoo NetworkManager[1233]: <info> (00:26:B0:D0:4F:AE): device state change: 3 -> 4 (reason 0)
Jul  9 13:08:08 djoo NetworkManager[1233]: <info> Activation (00:26:B0:D0:4F:AE) Stage 1 of 5 (Device Prepare) scheduled...
Jul  9 13:08:08 djoo NetworkManager[1233]: <info> Activation (00:26:B0:D0:4F:AE) Stage 1 of 5 (Device Prepare) started...
Jul  9 13:08:08 djoo NetworkManager[1233]: <info> Activation (00:26:B0:D0:4F:AE) Stage 2 of 5 (Device Configure) scheduled...
Jul  9 13:08:08 djoo NetworkManager[1233]: <info> Activation (00:26:B0:D0:4F:AE) Stage 1 of 5 (Device Prepare) complete.
Jul  9 13:08:08 djoo NetworkManager[1233]: <info> Activation (00:26:B0:D0:4F:AE) Stage 2 of 5 (Device Configure) starting...
Jul  9 13:08:08 djoo NetworkManager[1233]: <info> (00:26:B0:D0:4F:AE): device state change: 4 -> 5 (reason 0)
Jul  9 13:08:08 djoo NetworkManager[1233]: <info> Activation (00:26:B0:D0:4F:AE) Stage 2 of 5 (Device Configure) complete.
Jul  9 13:08:09 djoo bluetoothd[1405]: link_key_request (sba=00:23:4D:F9:17:7D, dba=00:26:B0:D0:4F:AE)
Jul  9 13:08:09 djoo bluetoothd[1405]: Invalid exchange (52)
Jul  9 13:08:09 djoo NetworkManager[1233]: <warn> Error connecting with bluez: Invalid exchange (52)
Jul  9 13:08:09 djoo NetworkManager[1233]: <info> (00:26:B0:D0:4F:AE): device state change: 5 -> 9 (reason 44)
Jul  9 13:08:09 djoo NetworkManager[1233]: <info> Marking connection 'Network Access Point on DeVO's iPhone' invalid.
Jul  9 13:08:09 djoo NetworkManager[1233]: <warn> Activation (00:26:B0:D0:4F:AE) failed.
Jul  9 13:08:09 djoo NetworkManager[1233]: <info> (00:26:B0:D0:4F:AE): device state change: 9 -> 3 (reason 0)
Jul  9 13:08:09 djoo NetworkManager[1233]: <info> (00:26:B0:D0:4F:AE): deactivating device (reason: 0).
Jul  9 13:08:09 djoo dbus-daemon: [system] Rejected send message, 3 matched rules; type="error", sender=":1.10" (uid=0 pid=1403 comm="/usr/sbin/bluetoothd) interface="(unset)" member="(unset)" error name="org.bluez.Error.Failed" requested_reply=0 destination=":1.1" (uid=0 pid=1233 comm="NetworkManager))
Jul  9 13:08:09 djoo NetworkManager[1233]: <info> (00:26:B0:D0:4F:AE): now unmanaged
Jul  9 13:08:09 djoo NetworkManager[1233]: <info> (00:26:B0:D0:4F:AE): device state change: 3 -> 1 (reason 36)
Jul  9 13:08:09 djoo NetworkManager[1233]: <info> (00:26:B0:D0:4F:AE): cleaning up...
Jul  9 13:08:09 djoo NetworkManager[1233]: <info> (00:26:B0:D0:4F:AE): taking down device.
------------------


Expected results:
tethering working

Additional info:
Comment 1 Bastien Nocera 2010-12-08 05:40:02 EST
Jul  9 13:08:09 djoo bluetoothd[1405]: Invalid exchange (52)
You might want to try and pair the device again.

Remove the iPhone as a device in the Bluetooth preferences, and start the pairing process again. Let me know if the problem still happens after re-pairing.
Comment 2 Bastien Nocera 2011-05-04 10:54:43 EDT

*** This bug has been marked as a duplicate of bug 577289 ***

Note You need to log in before you can comment on or make changes to this bug.