Bug 612873 - booting a machine with no output devices gives no console with nouveau driver
booting a machine with no output devices gives no console with nouveau driver
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-nouveau (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Ben Skeggs
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-09 05:48 EDT by Vladimir Benes
Modified: 2017-12-06 08:02 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-06 08:02:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir Benes 2010-07-09 05:48:53 EDT
Description of problem:
when using nouveau driver I cannot switch to console after booting the machine with no screens connected. With vesa everything works well

Version-Release number of selected component (if applicable):
kernel-2.6.32-44.el6.x86_64
xorg-x11-drv-nouveau-0.0.16-8.20100423git13c1043.el6


Steps to Reproduce:
1.boot up with no screens attached
2.switch to console

  
Actual results:
no console

Expected results:
console shown

Additional info:
similar problem was solved in bz580789
Comment 1 Ben Skeggs 2010-07-12 02:18:59 EDT
Interesting, I can't reproduce this issue here with the same kernel. I:

- booted without displays attached until gdm was up and running
- attached DVI, watched gdm appear at native resolution
- VT-switched to console and watched it appear at 1024x768

Are you able to attach dmesg output for your case (even better if you append "drm.debug=14" to your boot options), something may stick out there which gives a clue as to what's happening.
Comment 2 RHEL Product and Program Management 2011-01-06 23:33:30 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 3 RHEL Product and Program Management 2011-02-01 01:04:38 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 4 RHEL Product and Program Management 2011-02-01 13:27:29 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 5 RHEL Product and Program Management 2011-04-03 22:32:59 EDT
Since RHEL 6.1 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 6 Ben Skeggs 2011-08-24 00:55:21 EDT
Vladimir, any update here?
Comment 7 RHEL Product and Program Management 2011-10-07 12:15:57 EDT
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 10 Jan Kurik 2017-12-06 08:02:34 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.