Bug 612922 - [TAHI][NEMO][MR]mipv6-daemon can't send BU to HA as mobile router when MR(NUT) moves from Link0 to LinkX
[TAHI][NEMO][MR]mipv6-daemon can't send BU to HA as mobile router when MR(NUT...
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: mipv6-daemon (Show other bugs)
6.1
All Linux
high Severity high
: rc
: ---
Assigned To: Thomas Graf
qe-baseos-daemons
:
Depends On:
Blocks: 572236
  Show dependency treegraph
 
Reported: 2010-07-09 06:47 EDT by xhu
Modified: 2014-06-18 04:30 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause What actions or circumstances cause this bug to present. Consequence What happens when the bug presents. Fix What was done to fix the bug. Result What now happens when the actions or circumstances above occur. Note: this is not the same as the bug doesn’t present anymore.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-02 08:11:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
configure file for mipv6-daemon as mobile router (1.19 KB, application/octet-stream)
2010-07-09 06:47 EDT, xhu
no flags Details
log file for mipv6-daemon (15.19 KB, application/octet-stream)
2010-07-09 06:47 EDT, xhu
no flags Details
tcpdump file for Link0 (3.56 KB, application/octet-stream)
2010-07-09 06:48 EDT, xhu
no flags Details
tcpdump file for Link1 (3.13 KB, application/octet-stream)
2010-07-09 06:49 EDT, xhu
no flags Details

  None (edit)
Description xhu 2010-07-09 06:47:00 EDT
Created attachment 430623 [details]
configure file for mipv6-daemon as mobile router

Description of problem:
mipv6-daemon can't send BU to HA as mobile router when MR(NUT) moves from Link0 to LinkX. And there is an "process_first_home_bu: Failed to initialize new bule for HA" error in "mip6.tahi.log" attachment.
Note: 
NUT is short for Node Under Test.
Link0 	global 	3ffe:501:ffff:100::/64 	home link
LinkX 	global 	3ffe:501:ffff:200::/64  foreign link

Version-Release number of selected component (if applicable):
mipv6-daemon-0.4-3.el6.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
mipv6-daemon can't send BU to HA as mobile router when MR(NUT) moves from Link0 to LinkX.
The test details can be seen as follows:
1 The test topology and procedure can be seen in
http://focus.bne.redhat.com/~xhu/NEMO/ct-nemo-mr-rhel6-auto/nemo-mr/NEMO-MR-0-0-0-1-001.html
2 The test result can be seen in
http://focus.bne.redhat.com/~xhu/NEMO/ct-nemo-mr-rhel6-auto/nemo-mr/1.html
3 The tcpdumpfile can be seen in "1_html_Link0.pcap" and "1_html_Link1.pcap" attachment
4 The mipv6-daemon configure and log file can be seen in "mip6d.conf" and "mip6d.tahi.log" attachment

Expected results:
mipv6-daemon can send BU to HA as mobile router when MR(NUT) moves from Link0 to LinkX.

Additional info:
Comment 1 xhu 2010-07-09 06:47:53 EDT
Created attachment 430624 [details]
log file for mipv6-daemon
Comment 2 xhu 2010-07-09 06:48:34 EDT
Created attachment 430625 [details]
tcpdump file for Link0
Comment 3 xhu 2010-07-09 06:49:03 EDT
Created attachment 430627 [details]
tcpdump file for Link1
Comment 5 RHEL Product and Program Management 2010-07-15 11:13:31 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 8 Thomas Graf 2011-02-03 10:02:33 EST
mipv6-daemon-2.0.2.20110203bgit-1.el6 should fix this issue.
Comment 12 Florian Nadge 2011-03-02 12:38:15 EST
Please be so kind and add a few key words to the technical note of this
bugzilla entry using the following structure:

Cause:

Consequence:

Fix:

Result:


For details, see:
https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes

Thanks
Comment 13 Florian Nadge 2011-03-02 12:38:15 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause
    What actions or circumstances cause this bug to present.
Consequence
    What happens when the bug presents.
Fix
    What was done to fix the bug.
Result
    What now happens when the actions or circumstances above occur.

    Note: this is not the same as the bug doesn’t present anymore.
Comment 14 Suzanne Yeghiayan 2011-03-28 15:53:57 EDT
Since RHEL 6.1 External Beta has begun, and this bug remains 
unresolved, it has been rejected as it is not proposed as an 
exception or blocker.

Red Hat invites you to ask your support representative to 
propose this request, if appropriate and relevant, in the 
next release of Red Hat Enterprise Linux.
Comment 17 Tom Lavigne 2012-09-18 11:21:45 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.
    
Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.