Bug 612964 - cups printing to network printers delayed by failure to close connection
Summary: cups printing to network printers delayed by failure to close connection
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cups (Show other bugs)
(Show other bugs)
Version: 5.4
Hardware: All Linux
urgent
high
Target Milestone: rc
: ---
Assignee: Tim Waugh
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Keywords: ZStream
Depends On: 561946
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-09 12:18 UTC by RHEL Product and Program Management
Modified: 2010-11-22 23:39 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, sending a document to a network printer using the socket URI scheme could cause the actual printing to be delayed. This was due to the fact that the socket back-end used to wait for any pending back-channel data, even though the wait time option was set to zero. With this update, the pertinent "wait_bc" function call has been removed, and printing the document is no longer delayed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-10 12:46:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2010:0614 normal SHIPPED_LIVE cups bug fix update 2010-08-10 12:46:27 UTC

Description RHEL Product and Program Management 2010-07-09 12:18:46 UTC
This bug has been copied from bug #561946 and has been proposed
to be backported to 5.5 z-stream (EUS).

Comment 6 Jaromir Hradilek 2010-08-06 13:00:29 UTC
Technical note added. If any revisions are required, please edit the "Technical Notes" field
accordingly. All revisions will be proofread by the Engineering Content Services team.

New Contents:
Previously, sending a document to a network printer using the socket URI scheme could cause the actual printing to be delayed. This was due to the fact that the socket back-end used to wait for any pending back-channel data, even though the wait time option was set to zero. With this update, the pertinent "wait_bc" function call has been removed, and printing the document is no longer delayed.

Comment 7 errata-xmlrpc 2010-08-10 12:46:39 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0614.html


Note You need to log in before you can comment on or make changes to this bug.