Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 613009 - perftest terminates with signal 6
perftest terminates with signal 6
Status: CLOSED NOTABUG
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
Development
All Linux
urgent Severity medium
: ---
: ---
Assigned To: Kim van der Riet
MRG Quality Engineering
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-09 10:15 EDT by Jan Sarenik
Modified: 2011-08-12 12:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-16 07:18:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
GDB traceback (2.90 KB, text/plain)
2010-07-09 10:15 EDT, Jan Sarenik
no flags Details

  None (edit)
Description Jan Sarenik 2010-07-09 10:15:57 EDT
Created attachment 430684 [details]
GDB traceback

During cluster testing I found attached core file.
I hope you will know what to do with it.

qpid-cpp-client-devel-0.7.946106-6.el5

How reproducible: Occasionally (probably on broker exit, while
the client was still running).

Steps to Reproduce:
1. Run two brokers in a cluster (but maybe this is not vital)
2. while qpid-perftest --base-name prvy; do :; done
3. Shut down the broker on which perftest is connected.
  
Actual results: Core is dumped.
Expected results: Connection should be closed cleanly on the client side.
  Without core file.

Additional info:
  Happened on mrg26.lab.bos.redhat.com
Comment 1 Kim van der Riet 2010-07-12 11:09:25 EDT
I am unable to reproduce this after many runs on mrg10. Could you give a little more information, please?

1. Were the brokers running on the same box as the client (perftest)?
2. How were the brokers started (ie what command-line options)?
3. How was the broker stopped? ie Ctl-C (SIGTERM) or kill/pkill -9 (SIGKILL)?
4. What is the timing between starting perftest and killing the broker?
Comment 2 Jan Sarenik 2010-07-19 10:07:14 EDT
Sorry, I was in a hurry that time and did not note the exact settings
into the description.

I was running the brokers with:
on mrg26: qpidd --known-hosts-url amqp:tcp:20.0.20.26,rdma:192.168.55.26 --cluster-name=ahoj --cluster-url amqp:rdma:192.168.55.26 --tcp-nodelay
on mrg25: qpidd -m1 --port=12345 --cluster-name=ahoj --cluster-url amqp:rdma:192.168.55.25:12345 --known-hosts-url amqp:tcp:20.0.10.25:12345,rdma:192.168.55.25:12345 --tcp-nodelay

and killed the broker on mrg26 with CTRL-C. Perftest was running on mrg26.

The timing between starting perftest and killing the broker is the most
fuzzy thing here. I do not know and the core was emitted when I was not
focusing at that window with perftest so I found it just acccidentally
when switching among windows (in screen(1)).
Comment 3 Kim van der Riet 2010-08-30 14:16:05 EDT
I have not succeeded in reproducing this as yet; I suggest moving it out of 1.3.
Comment 5 Jan Sarenik 2010-09-16 09:16:59 EDT
As far as I remember, I was not able to reproduce it with later versions.
Yes please, I am moving it into 1.3.1 and will re-test later, then
probably close if it will not show up anymore.
Comment 7 Jan Sarenik 2011-03-16 07:18:46 EDT
I am closing this as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.