Bug 61304 - hp laserjet 4l does not print properly once printconf-0.3.61 is installed
hp laserjet 4l does not print properly once printconf-0.3.61 is installed
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: printconf (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-16 14:44 EST by Tim Woodall
Modified: 2007-04-18 12:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 10:24:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
local.adl as requested (this is the with 0.3.52 version of printconf installed) (528 bytes, application/octet-stream)
2002-03-18 09:42 EST, Tim Woodall
no flags Details
tests.tar.gz as described in the main comments (236.13 KB, application/octet-stream)
2002-03-19 15:09 EST, Tim Woodall
no flags Details

  None (edit)
Description Tim Woodall 2002-03-16 14:44:43 EST
Description of Problem:
hp laserjet 4l does not print properly once printconf-0.3.61 (and printconf-gui) are installed. (Works fine with version 0.3.52)

Version-Release number of selected component (if applicable):
printconf-0.3.61 and printconf-gui-0.3.61

How Reproducible:
Every time

Steps to Reproduce:
1. Select ljet4 driver for hp laserjet 4l printer in printconf gui.
2. Select A4 paper.
3. Open any pdf/ps with 3 or more pages using gv.
4. Select print document
5. First page will print (second page _very_ occasionally will print) then printing stops. Printer has about 1/2 page in buffer.

It appears that, once the printer buffer is full and the computer has to pause, no further data is sent to the printer.

Selecting the omni driver appears to work but at a rate of about 1 page per 2 minutes (something like 1/4 to 1/8 expected speed) (and 100% cpu 
usage). Printer is on a P300

The data is still in the print queue lpq lists it.

Actual Results:
Printing stops part way through a document

Expected Results:
Document prints

Additional Information:

The print postscript A4 test page is shifted up by about 2 cm. The "2cm" apears at the top of the page but neither of the 1 or 2cm lines are 
visible. Version 0.3.52 prints as expected, fully centered on the page.

The omni driver shifts the page right by about 0.75 cm and up even more (~2.5cm)(I haven't tried the omni driver on version 0.3.52)

(I can attach scans of the top inch or so of each test print to demonstrate the shifting if required (20Kb each))
Comment 1 Tim Waugh 2002-03-18 05:54:10 EST
Please attach your /etc/alchemist/namespace/printconf/local.adl file.
Comment 2 Tim Woodall 2002-03-18 09:42:19 EST
Created attachment 48864 [details]
local.adl as requested (this is the with 0.3.52 version of printconf installed)
Comment 3 Tim Waugh 2002-03-18 10:19:11 EST
Thanks.  Can you take a look around in your spool directory (/var/spool/lpd/lp)
and see if you can find a file that looks like a log of what's gone on, once
you've tried to print using 0.3.61?  Are there any error messages that you can see?

Does changing either the 'send FF' flag or the 'send EOT' flag help at all?
(Probably not, but please try so we can rule that out.)
Comment 4 Tim Woodall 2002-03-18 11:14:18 EST
Send FF doesn't make any difference. I tried that one before.
I haven't tried EOT.

I won't be able to do any tests until Tuesday evening (GMT i.e. about 27 hours from now)


Comment 5 Tim Woodall 2002-03-19 15:06:28 EST
I am now doing some more tests. Prior to starting these tests I had the 0.3.52 version installed and everything was working correctly.
All other packages have the most up to date version installed.

Test1.

1. (as root) rpm -Fvh printconf*61*
	upgraded printconf and printconf-gui successfully

2. Logged into X (kde) as tim

3. Opened a shell (console) and typed gv econ.ps. This is an 8 page paper.

4. Did File:Print Document.

The printer lights came on - printer was in powersave mode.
Then the data light flashed a few times. 
Then nothing. No pages have been printed (Previously the first page has always succeeded)

typing lpq gives:
Printer: lp@pauli
 Queue: no printable jobs in queue
 Status: removing job 'cfA460pauli.locofungus.org' - JREMOVE at 19:26:04.096

typing lprm gives:
Printer lp@pauli

And then lpq gives the same output as before.

A single short press of the printer control button (formfeed) results in a blank page being printed.

Then doing /etc/init.d/lpd restart is successful but lpq still gives the same message.

Now runnning printer-configuration in X for the first time since the upgrade.
(A check of the parameters all looks correct). Then do Apply - Message lpd restart succeeded.

lpq still gives the same message.

Then do another print document from gv (time is 19:48)

First four pages print ok. (I ran top as the fourth page was printing and the load average was 0.14)
Then the printing stops.

lpq now gives:
Printer: lp@pauli
 Queue: 1 printable job
 Server: pid 13683 active
 Unspooler: pid 13684 active
  Status: IF filter 'mf_wrapper' filter msg - 'Loading NimbusSanL-Regu font from /usr/share/fnts/default/Type1/no190031.pfb... 2680988 1269462 
1642520 335588 0 done.' at 19:49:05.360
Rank   Owner/ID        Class   Job   Files     Size   Time
1      tim@pauli+682    A       682  econ.ps   553593 19:49:03

A printer formfeed then results in the top 1/3 of the fifth page printing - the last line of text is cut along its centre line.

I will attach a files tests.tar.gz that contains the following:

test1.ps - output of ps aux after the first print
test1.local.adl - the local.adl file as before
test1.lp.tar - a tar of the /var/spool/lpd/lp directory
test2.ps - output of ps aux and then ps ax after the second print
test2.local.adl - the local.adl file
test2.lp.tar - another tar of the /var/spool/lpd/lp directory

Finally:

#lprm
Printer lp@pauli:
  checking perms 'tim@pauli+682'
  dequeued 'tim@pauli+682'
#lpq
Printer: lp@pauli
  Queue: no printable jobs in queue
  Status: subserver pid 13684 exit status 'JFAIL' at 20:04:36.824

Comment 6 Tim Woodall 2002-03-19 15:09:44 EST
Created attachment 49044 [details]
tests.tar.gz as described in the main comments
Comment 7 Tim Woodall 2002-03-19 15:22:00 EST
Now trying the EOT/FF flags. No differences (except that now I am back to just the first page)

However the very first print (FF+EOT) gave a page that had

@PJL SET MANUALFEED=OFF
                       @PJL SET RET=MEDIUM
etc
but then the first page printed correctly - this could be due to stuff in the printer buffer from a previous print as I didn't hard reset the 
printer before this test.


Comment 8 Tim Waugh 2002-04-04 09:07:09 EST
Do you have mpage installed?
Comment 9 Tim Woodall 2002-04-04 10:27:29 EST
Yes. mpage-2.5.1-7
Comment 10 Need Real Name 2002-05-18 20:30:32 EDT
I had the exact same problem with RH7.2 on my LaserJet4L.  I tried fiddling with
all the configuration options with no luck.  A windows machine could print via
SMB  through the linux box with no problems. (e.g. no need to hit the reset button)

The problem went away after I upgraded to RH7.3 and switch to CUPS.
Comment 11 Tim Waugh 2002-07-04 12:44:58 EDT
Are either of you in a position to be able to test out the Red Hat Linux Beta 
(Limbo) to see if this problem is still there?
Comment 12 Bill Nottingham 2006-08-07 13:20:43 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 13 Bill Nottingham 2006-10-18 10:24:59 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.