Bug 613082 - xterm crashes when changing fonts in rawhide
xterm crashes when changing fonts in rawhide
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
14
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-09 12:26 EDT by lethalwp
Modified: 2010-08-11 12:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-11 12:38:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lethalwp 2010-07-09 12:26:58 EDT
Description of problem:
xterm crashes when changing fonts with the error:
xterm:  fatal IO error 11 (Resource temporarily unavailable) or KillClient on X server ":0.0"

Version-Release number of selected component (if applicable):
xterm-261-2.fc14
xorg-x11-server-common-1.8.99.904-3.20100702.fc14.x86_64
xorg-x11-server-Xorg-1.8.99.904-3.20100702.fc14.x86_64
libXft-2.1.14-1.fc13.x86_64
libXfont-1.4.2-1.fc14.i686


How reproducible:
always

Steps to Reproduce:
1. open xterm
2. left shift + left alt +  "+" from numeric keypad, 3 or 4 times will result in the crash;   same if you ctrl + leftclick and change the fonts to "Huge" (some other settings may crash too)
3.
  
Actual results:
crash

Expected results:
bigger window

Additional info:

this seems to be font related,  when doing ltrace xterm:
(snip till the problem occured):
strlen("-Misc-Fixed-bold-R-*-*-20-200-75"...)    = 41
strlen("-Misc-Fixed-bold-R-*-*-20-200-75"...)    = 41
strcat("-Misc-Fixed-bold-R-*-*-20-200-75"..., "ISO8859-1") = "-Misc-Fixed-bold-R-*-*-20-200-75"...
XLoadQueryFont(0x219f650, 0x2203d40, 0x7fff72e8bc60, 2, 0 <unfinished ...>
__errno_location()                               = 0x7f508e0cf6e8
strerror(11)                                     = "Resource temporarily unavailable"
__fprintf_chk(0x7f508c82c860, 1, 0x44b108, 0x445262, 11xterm:  fatal IO error 11 (Resource temporarily unavailable) or KillClient on X server ":0.0"
) = 95
removeFromUtmp(84, 95, 0x7f508c82de20, 1, 0x7f508e0cf740 <unfinished ...>
--- SIGCHLD (Child exited) ---
Comment 1 Thomas E. Dickey 2010-07-12 05:09:37 EDT
In a quick check, I'm not seeing this break.

#261 doesn't touch anything related.  Perhaps one of the ongoing
changes I've made to reduce the use of the "term" variable (in
#260 for instance) is breaking.
Comment 2 lethalwp 2010-07-12 05:21:09 EDT
it was working well in fc13,  took the xterm.src.rpm from f13, and installed on this system,  problem remains.

It's more likely to be a Xserver, fontserver(/libs), or other lib problem.

How could i help debugging this? Can you confirm the crash on another rawhide system?
Comment 3 Thomas E. Dickey 2010-07-12 05:26:42 EDT
At the moment I have a f12 (64-bits), but am running Debian/testing (32-bits).
I can install f13 (perhaps tomorrow), and compare more directly.

Do you get a core dump from the crash?  A traceback from that would be helpful.
Comment 4 Thomas E. Dickey 2010-07-12 05:30:44 EDT
hmm - I finally see the f14 remark.  Perhaps you've not installed
the miscellaneous fonts package, and there's (still) a hole in the
checks for absent bitmap fonts.
Comment 5 lethalwp 2010-07-12 06:02:48 EDT
There is no coredump, but just the error:
xterm:  fatal IO error 11 (Resource temporarily unavailable) or KillClient on X server ":0.0"

when ltracing, the last relevant line is:
strcat("-Misc-Fixed-bold-R-*-*-20-200-75"..., "ISO8859-1") =
"-Misc-Fixed-bold-R-*-*-20-200-75"...
(before the XLoadFont)


when listing with xlsfont it looks i have no matching font with these requirements


I did a yum install of every package with font & bitmap included,
and also did a yum groupinstall of "Fonts" and "Legacy Fonts"


And to avoid user environment dependancies, i've tried with a newly created user


How can i find the required package (if it exists?)
Comment 6 Thomas E. Dickey 2010-07-12 06:53:25 EDT
yum has an option for listing available packages.

In my f12, I have this, which iirc contains the needed fonts:

xorg-x11-fonts-misc-7.2-9.fc12.noarch
Comment 7 lethalwp 2010-07-12 08:22:54 EDT
thx for your reply,

here are the xorg fonts installed:
 ~]$ rpm -qa | grep -i xorg | grep -i fonts
xorg-x11-fonts-ISO8859-2-100dpi-7.2-11.fc14.noarch
xorg-x11-fonts-ISO8859-1-75dpi-7.2-11.fc14.noarch
xorg-x11-fonts-100dpi-7.2-11.fc14.noarch
xorg-x11-fonts-ISO8859-14-75dpi-7.2-11.fc14.noarch
xorg-x11-fonts-75dpi-7.2-11.fc14.noarch
xorg-x11-fonts-ISO8859-15-100dpi-7.2-11.fc14.noarch
xorg-x11-fonts-ISO8859-2-75dpi-7.2-11.fc14.noarch
xorg-x11-fonts-ISO8859-15-75dpi-7.2-11.fc14.noarch
xorg-x11-fonts-ISO8859-9-100dpi-7.2-11.fc14.noarch
xorg-x11-fonts-misc-7.2-11.fc14.noarch
xorg-x11-fonts-ISO8859-9-75dpi-7.2-11.fc14.noarch
xorg-x11-fonts-ethiopic-7.2-11.fc14.noarch
xorg-x11-fonts-cyrillic-7.2-11.fc14.noarch
xorg-x11-fonts-ISO8859-1-100dpi-7.2-11.fc14.noarch
xorg-x11-fonts-Type1-7.2-11.fc14.noarch
xorg-x11-fonts-ISO8859-14-100dpi-7.2-11.fc14.noarch


but also have plenty of others (152 packages with "font" & without ^xorg)


By googling the fontname, i'm not sure a fixed-bold-20-200 font exist at all,
it looks like xterm is inventing the name? Maybe it worked in f13 because of the 'non existant font protection', which rawhide now temporarily lacks, as you've suggested.

i think it could be locally fixed by adding a specific xterm font listing to xresources or whatever.

I'm not sure this is the correct way to do it
Comment 8 Thomas E. Dickey 2010-07-12 16:32:51 EDT
xterm asks the font server for that combination, and the font server
provides something (usually ;-).  Even if the font server cannot
provide, it shouldn't produce an error.
Comment 9 Miroslav Lichvar 2010-07-14 10:44:12 EDT
Reassigning to xorg-x11-server.
Comment 10 Bug Zapper 2010-07-30 08:29:36 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 lethalwp 2010-08-11 12:38:05 EDT
fixed with update libX11-1.3.4-3,
closing this issue

Note You need to log in before you can comment on or make changes to this bug.