Bug 613091 - PangoWarning: failed to choose a font, expect ugly output (via virt-manager)
PangoWarning: failed to choose a font, expect ugly output (via virt-manager)
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pango (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: 6.0
Assigned To: Matthias Clasen
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-09 12:46 EDT by Eric Sammons
Modified: 2010-10-23 11:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-12 12:19:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Sammons 2010-07-09 12:46:31 EDT
Description of problem:
All the the text in virt-manager is displayed as small squares, see the attached bitmap

Version-Release number of selected component (if applicable):
virt-manager-0.8.4-3.el6


How reproducible:
Very

Steps to Reproduce:
1. Install virt-manager
2. Run virt-manager
  
Actual results:
Text in virt-manager displays as squares.


Expected results:
Text should display
Comment 5 Cole Robinson 2010-07-12 10:37:24 EDT
I can't imagine this is specific to virt-manager. Do other graphical apps have similar issues? Maybe a base package somewhere is missing a proper fonts dep.

Reassigning to pango since it's giving us an error message.
Comment 6 Matthias Clasen 2010-07-12 11:40:55 EDT
Sure, if you don't install any fonts, then all graphical apps have the same problem.
Comment 7 Bill Nottingham 2010-07-12 12:19:04 EDT
This isn't really something that can be expressed in a dependency, though, as the app may need different fonts depending on the locale.

If you need fonts for graphical apps, install the 'fonts' group. This is going to be part of the documentation, see bug 607057.

Note You need to log in before you can comment on or make changes to this bug.