Bug 61315 - Can't upgrade nor install. Installer doesn't find SCSI disk
Can't upgrade nor install. Installer doesn't find SCSI disk
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: parted (Show other bugs)
7.2
i386 Linux
high Severity high
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-17 08:28 EST by meyer@princeton.edu
Modified: 2005-10-31 17:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-25 14:29:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda crap out bug dump file (29.76 KB, text/plain)
2002-03-17 08:30 EST, meyer@princeton.edu
no flags Details
readout of dd if=/dev/sda of=sdaFirstBlock count=1 bs=1M (1.00 MB, application/octet-stream)
2002-03-29 17:08 EST, meyer@princeton.edu
no flags Details

  None (edit)
Description meyer@princeton.edu 2002-03-17 08:28:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (Win98; U)

Description of problem:
I try to upgrade from 7.1 to RH 7.2.  Installer says there's no linux on the 
computer.  It bobbles when left to its own devices in loading SCSI disk 
controller aix7xxx.  Used 'linux noprobe apic updates update' and installed 
aix7xxx manually.  Still says no linux system.  When checking Disk Druid...  
only my DOS IDE drive is shown.  The SCSI drive Linux lives on doesn't appear 
in Disk Druid.  Entering the SCSI manually, installer says it finds the SCSI 
device.  But it still craps out.  I have the bug report anacdump.txt.  Is there 
somewhere on this page to include it?  Or how do I get it to you?  It's not 
doing me much good here!!!  Here's the end of the anacdump.txt:
~~~~~~~helluva lot more stuff above here~~~snip~~~~~~~~~~
<5>RAMDISK: Compressed image found at block 0
<4>Freeing initrd memory: 2046k freed
<4>EXT2-fs warning: checktime reached, running e2fsck is recommended
<4>VFS: Mounted root (ext2 filesystem).
<6>SCSI subsystem driver Revision: 1.00
<6>usb.c: registered new driver usbdevfs
<6>usb.c: registered new driver hub
<6>usb-uhci.c: $Revision: 1.259 $ time 16:21:20 Sep  6 2001
<6>usb-uhci.c: High bandwidth mode enabled
<6>PCI: Found IRQ 10 for device 00:1f.2
<6>PCI: Sharing IRQ 10 with 02:0b.0
<4>PCI: Setting latency timer of device 00:1f.2 to 64
<6>usb-uhci.c: USB UHCI at I/O 0xef80, IRQ 10
<4>usb-uhci.c: Detected 2 ports
<6>usb.c: new USB bus registered, assigned bus number 1
<6>hub.c: USB hub found
<6>hub.c: 2 ports detected
<6>usb-uhci.c: v1.251:USB Universal Host Controller Interface driver
<6>hub.c: USB new device connect on bus1/1, assigned device number 2
<4>usb.c: USB device 2 (vend/prod 0x781/0x2) is not claimed by any active 
driver.
<6>usb.c: registered new driver hid
<6>usb.c: registered new driver hiddev
<6>hid-core.c: v1.8 Andreas Gal, Vojtech Pavlik <vojtech@suse.cz>
<6>hid-core.c: USB HID support drivers
<6>Initializing USB Mass Storage driver...
<6>usb.c: registered new driver usb-storage
<4>usb-uhci.c: interrupt, status 2, frame# 676
<4>usb-uhci.c: interrupt, status 3, frame# 677
<6>scsi0 : SCSI emulation for USB Mass Storage devices
<4>  Vendor: SanDisk   Model: ImageMate II      Rev: 1.30
<4>  Type:   Direct-Access                      ANSI SCSI revision: 02
<4>Attached scsi removable disk sda at scsi0, channel 0, id 0, lun 0
<4>usb-uhci.c: interrupt, status 3, frame# 697
<4>usb-uhci.c: interrupt, status 3, frame# 711
<4>usb-uhci.c: interrupt, status 3, frame# 725
<4>sda : READ CAPACITY failed.
<4>sda : status = 1, message = 00, host = 0, driver = 08 
<4>Current sd00:00: sns = 70  2
<4>ASC=3a ASCQ= 0
<4>Raw sense data:0x70 0x00 0x02 0x00 0x00 0x00 0x00 0x12 0x00 0x00 0x00 0x00 
0x3a 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
<4>sda : block size assumed to be 512 bytes, disk size 1GB.  
<6> sda: I/O error: dev 08:00, sector 0
<4> unable to read partition table
<7>WARNING: USB Mass Storage data integrity not assured
<7>USB Mass Storage device found at 2
<6>USB Mass Storage support registered.
<7>ISO 9660 Extensions: RRIP_1991A
<4>Unable to identify CD-ROM format.
<4>VFS: Can't find ext2 filesystem on dev loop(7,0).
<6>PCI: Found IRQ 9 for device 02:09.0
<6>PCI: Sharing IRQ 9 with 00:1f.3
<6>PCI: Found IRQ 9 for device 02:09.0
<6>PCI: Sharing IRQ 9 with 00:1f.3
<6>(scsi1) <Adaptec AIC-7860 Ultra SCSI host adapter> found at PCI 2/9/0
<6>(scsi1) Narrow Channel, SCSI ID=7, 3/255 SCBs
<6>(scsi1) Cables present (Int-50 YES, Ext-50 NO)
<6>(scsi1) Downloading sequencer code... 436 instructions downloaded
<6>scsi1 : Adaptec AHA274x/284x/294x (EISA/VLB/PCI-Fast SCSI) 5.2.4/5.2.0
<4>       <Adaptec AIC-7860 Ultra SCSI host adapter>
<4>  Vendor: SEAGATE   Model: ST39216N          Rev: 0010
<4>  Type:   Direct-Access                      ANSI SCSI revision: 03
<4>Attached scsi disk sdb at scsi1, channel 0, id 0, lun 0
<6>(scsi1:0:0:0) Synchronous at 20.0 Mbyte/sec, offset 15.
<4>SCSI device sdb: 17942584 512-byte hdwr sectors (9187 MB)
<6> sdb: sdb1 sdb2 < sdb5 sdb6 >
<6>md: raid0 personality registered as nr 2
<6>md: raid1 personality registered as nr 3
<6>raid5: measuring checksumming speed
<4>   8regs     :  1542.400 MB/sec
<4>   32regs    :   861.200 MB/sec
<4>   pII_mmx   :  2108.000 MB/sec
<4>   p5_mmx    :  2223.600 MB/sec
<4>raid5: using function: p5_mmx (2223.600 MB/sec)
<6>md: raid5 personality registered as nr 4
<6>Journalled Block Device driver loaded
<4>spurious 8259A interrupt: IRQ7.
<6>cdrom: open failed.
<3>ide-floppy: hdb: I/O error, pc =  0, key =  2, asc = 3a, ascq =  0
<3>ide-floppy: hdb: I/O error, pc = 1b, key =  2, asc = 3a, ascq =  0
<3>hdb: No disk in drive
<3>ide-floppy: hdb: I/O error, pc = 5a, key =  5, asc = 24, ascq =  0
<6>Device not ready.  Make sure there is a disc in the drive.
<4>usb-uhci.c: interrupt, status 3, frame# 587
<4>usb-uhci.c: interrupt, status 3, frame# 601
<4>usb-uhci.c: interrupt, status 3, frame# 615
<4>sda : READ CAPACITY failed.
<4>sda : status = 1, message = 00, host = 0, driver = 08 
<4>Current sd00:00: sns = 70  2
<4>ASC=3a ASCQ= 0
<4>Raw sense data:0x70 0x00 0x02 0x00 0x00 0x00 0x00 0x12 0x00 0x00 0x00 0x00 
0x3a 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
<4>sda : block size assumed to be 512 bytes, disk size 1GB.  
<6> sda: I/O error: dev 08:00, sector 0
<4> unable to read partition table


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.PUt the install disk in, run through it.
2.get to upgrade choice.  Choose upgrade
3.Damn thing says there's no linux system to upgrade
4.Go back to choice
5. Choose 'install workstation'
6.Go to Disk Druid
7. Disk Druid only says I have hda on my system (the IDE drive)
8. But system has IDE and the SCSI.  In spite of loading SCSI driver,
doesn't recognize SCSI drive.  BUT SCSI drive was located, formatted, etc. by 
RH version 7.1.  What screwed up between 7.1 and 7.2?????
	

Actual Results:  Nothing.  Nada.  Zilch. Can't upgrade.  Can't even install.  
Yet 7.1 runs fine on the SCSI disk.

Expected Results:  I SHOULD have been able to upgrade the RH 7.1 system on the 
SCSI drive Linux lives on to RH 7.2!!! 

Additional info:

SCSI card (works perfectly with 7.1!!!!!) is an Adaptec AHA 2930, SCSI Bios V. 
1.34.1
Comment 1 meyer@princeton.edu 2002-03-17 08:30:10 EST
Created attachment 48786 [details]
Anaconda crap out bug dump file
Comment 2 Jeremy Katz 2002-03-18 15:11:35 EST
If you boot with the updated boot disks available from our FTP site in the
updates area and boot with 'linux nousbstorage' does it work better?
Comment 3 meyer@princeton.edu 2002-03-19 09:20:54 EST
Tried using the nousbstorage--same result: at upgrade: no linux system on this 
computer!  (but there is!  RH 7.1!!!)  I used the 7.1 auto config disk--which 
did strange things different in terms of setting up the SCSI didk than disk 
druid or fdisk...  when I installed 7.1.  I DID try installing at the noprobe 
'what device' prompt, several different Adaptec drivers, but Linux only took 
the aic7xxx one... and found the card.  On backing up from the 'there's no 
Linux system' error message at update this time, however, and trying install 
workstation and use disk druid, I got an error message saying something like 
the formatting of the SCSI disk is a non-standard format, and asking whether to 
reformat the disk.  I didn't do that as I hadn't the time at the moment... but 
it would seem the 7.1 auto-setup installation did something crazy to the disk? 
 But 7.1 runs fine.  So what gives????
Comment 4 meyer@princeton.edu 2002-03-19 11:52:23 EST
Added note...  Boot disk and updates from RH FTP site have been being used for
all these attempts since the first ones a couple of weeks ago!  Thay ain't 
hackin' it!  Not yet, at least.
Comment 5 meyer@princeton.edu 2002-03-23 08:15:41 EST
This morning I tried AGAIN!!!
Command given at using new RH boot disk (as I have all along!) was:
Linux nousbstorage noprobe apic updates update
Upon the 'add device' window:
tried all adaptec devices. Got message 'module not loaded' until I
tried the usual aic7xxx.
message there was:
"I have found the following deviced in your system:'
Adaptec AHA-2740, 28xx, 29xx, 39xx
Then added 3com ethernet card:
same message then had that plus
3COM 3c590/3c595/3c90x/3cx980
as having been found
Then added the RH updates (downloaded at the same time several weeks ago as the 
updated boot disk.) when called for.
went through the monitor probe, chose English as lang, 101key keyboard, PS2 
intellimouse, and update screen came up with the same damn message...
'There is no linux system on this computer' or words to that effect...  
DESPITE THE FACT THAT JUST YESTERDAY I WAS WORKING ON A BOOK IN RH LINUX 7.1 ON 
THE SCSI DISK ON THIS COMPUTER!!!!  AS HAS been previously noted in this bug 
report...

So, I backed up to the anaconda screen where one chooses whether to install or 
upgrade with the various choices, chose AGAIN!!!  'Install Workstation', 
'next', chose Disk Druid and AGAIN the DAMN THING only found hda as the disk on 
the computer.  THIS despite the fact that aic7xxx found the SCSI card and 
should have found the disk!!!!
So, I backed up to the choose what to partition the disk with and this time 
chose fdisk... And guess what???  fdisk's next page showed buttons both for hda 
and for sda!!!  I punched the sda button and got the following message:
"The number of sylinders for this disk is set to 1116.
There is nothing wrong with thios, but this is larger than 1024 and could in 
certain setups cause problems with:
1)software that runs at boot time (e.g., old versions of LILO)
2)booting and partitioning software fromother OSs (e.g., DOS fdisk., OS2 fdisk)

On running 'p' at the fdisk prompt to print sda's partitioning table (WHICH 
ANACONDA APPARENTLY is TOO DAMN DUMB TO FIND) I got the following:

"
Disk /tmp/sda: 255 heads, 63 sectors, 1116 cylinders
Units = cylinders of 1`6065 * 512 bytes

Device    Boot Start End   Blocks  ID  System
/tmp/sda1   *    1     7    56196  83  Linux
/tmp/sda2        8  1116  8908042+  5  Extended
/tmp/sda5        8   819  6522358+ 83  Linux
/tmp/sda6      820   885   530113+ 82  Linux Swap
"

I then quit the table without saving given that it already was obvious setup 
since fdisk merely printed out the already present partition information.

So fdisk finds the SCSI disk.  Either that or some gremlin is printing out the 
table to play fun and games and letting me run the linux which 7.2 says isn't 
there.  So what gives?  What's screwed up with anaconda that it or disk druid 
doesn't recognize the automatically set up disk partitioning that your RH 7.1 
did (for it was 7.1 that set up THAT partition table on the SCSI 
disk!!!--I wouldn't have set it up that way, but left 7.1 do its thing 
automatically.... so what's with this that 7.2's install/update program can't 
recognize the setup and partitioning of a disk 7.1 did???????

I didn't want to write the partition table fdisk found back to the disk as 7.1 
is running all right now, and the way anaconda is screwed up, I don't want to 
get rid of 7.1 until I've got clear indication from you guys that you have 7.2 
fixed the way it ought to be....

and When's that going to happen???

I'm still waiting for word!!!!
Comment 6 meyer@princeton.edu 2002-03-28 17:35:00 EST
I note from the e-mail I just got that there is an update to this bug.... but I 
don't see anything here.  What's up?
Comment 7 Jeremy Katz 2002-03-28 17:36:39 EST
If you go to tty2 and do

mknod /tmp/sda
parted /tmp/sda
  print


What is printed out?
Comment 8 meyer@princeton.edu 2002-03-29 06:53:54 EST
You didn't give enough information....
When and where am I to go to TTY2 and do:
mknod /tmp/sda
parted /tmp/sda
print
?
I tried doing this after logging in to RH7.1 (the system I'm trying to upgrade)
and i get error messages from mknod indicating there are supposed to be options
set that aren't given in your directions... Or is this supposed to be done when
trying to boot from the new boot disk, and if so, when?  any time? After the
thing says I haven't a Linus system?  When?  Please supply further
information...  I can't determine what you have in mind.  I'll go ahead and see
what happens with the boot disk attempt...  but if mknod spits me out there,
I'll have to await your fuller directions.

Thanks!
Comment 9 meyer@princeton.edu 2002-03-29 07:36:59 EST
OK. Ran the updated install bootdisk & upgrades to Anaconda...
command @ startup:
Linux nousbstorage noprobe apic updates update
loaded aic7xxx and the 3com Network card driver
Chose 'update'
Got the usual 'No linux system on this computer' message...
Did Ctrl-Alt-F2 to TTY2 (had to fiddle to get there, usually use Alt-F2 and 
that didn't work in this case... but got the shell prompt#..
ran:
mknod /tmp/sda
parted /tmp/sda
Message following usual FSA disclaimers...
"
Warning: The operating system thinks the gwometry on /tmp/sda is 1116/255/63.  
Therefore cylinder 1024 ends at 8032.499M.  You should check this matches GIOS 
geometry before using this program.
"
Then at the (parted) prompt I did:
(parted)print
and got:
"
Disk geometry for /tmp/sda: 0.000-8761.027 megabytes
Disk Label type: mac
Minor Start     End    Filesystem   Name                Flags
1     0.000     0.031               Apple
2     0.031     0.093               Macintosh_SL
3     0.094     6.050                 LaCie Utilities
4     6.051  8760.933               LaCie 8900
"
The above is a verbatum account of the results of mknod & parted as directed.
It puzzles me as to where the Apple/Macintosh_SL stuff comes from as RH Linux 
7.1 was what automatically initialized the SCSI drive on which 7.1 lives.  
Which is why it puzzles me even more that 7.2 can't recognize what 7.1 did!
Anyway... the above is the readout you requested...
Let me know if you need anything more.  This gets, as the March Hare said....
"Curiouser and curiouser..."
Thanks!
Comment 10 Jeremy Katz 2002-03-29 14:37:44 EST
That's strange...  reassigning to msw because weird parted problems are all him.
 He'll probably want a copy of the first meg or so of the disk to get the
partition table to look at -- you can get this with 'dd if=/dev/sda of=file
count=1 bs=1M' from your installed linux system and then attaching file.  

But the reason it's failing is that parted doesn't see any filesystems we know
how to mount, so we don't try to mount any of them.
Comment 11 meyer@princeton.edu 2002-03-29 17:03:30 EST
OK Here's the result of running as root on the 7.1 Sda disk the command:
dd if=/dev/sda of=sdaFirstBlock count=1 bs=1m
I'll send the file as an attachment if I can find a wya of attaching it
Comment 12 meyer@princeton.edu 2002-03-29 17:08:04 EST
Created attachment 51426 [details]
readout of dd if=/dev/sda of=sdaFirstBlock count=1 bs=1M
Comment 13 meyer@princeton.edu 2002-03-29 17:09:08 EST
Attachment sent as octet stream.
Comment 14 Andrew Clausen 2002-04-03 22:09:01 EST
hi, this hard disk has two partition tables on it... one a vanilla PC partition
table,
the other a macintosh table.

Anaconda is seeing the macontish one.

Quick-hack solution:
echo 'x' > /dev/sda

This will make the MBR unbootable, but it looks like it's unbootable anyway.

So, any theories as to why there's a mac table on their?  Maybe the SCSI
disk was sold with a Mac?
Comment 15 Matt Wilson 2002-04-04 11:29:44 EST
Some additional info - 7.2 was the first installer that actually recognized Mac
partitions.  This Mac partition table was probably there when you installed 7.1,
but wasn't seen until 7.2.  This is a Hard Problem to fix.
Comment 16 meyer@princeton.edu 2002-04-04 12:04:12 EST
I have no idea why there was/is a MAC partition table on the SCSI disk.  It was 
bought around RH V. 6.2 time from PC Connections, Upgraded to RH 7.0, then 7.1, 
and at 7.1 I let 7.1 do an automatic partitioning of the disk on its own rather 
than using Disk Druid or FDisk.  7.1 has been running merrily along on the disk 
with no problems (booting from LILO on the IDE disk that contains Windoze ME).  
Didn't buy the disk from PC Connections for a MAC.  (unless they foisted one on 
me, which is unlikely, though maybe a mistake?)  Can FDisk unscrew the screwed 
up Partition Table?  I have all the important stuff (well mostly) backed up in 
a couple of tarballs so FDisking it (FDisk seems to recognize the disk as 
/tmp/sda) would not be a problem as long as FDisk doesn't screw around with the 
IDE drive.  Suggestions?

BTW - on the quick hack you mentioned: "echo 'x' > /dev/sda" --when and where 
should one run that hack?  TTY 2 during installation bootup? Then reboot? What? 
What?  (should be done when, that is...)
Comment 17 marty rampton 2002-04-10 01:24:45 EDT
i had a similar problem.

seems like the aic7xxx drivers are crippled.

after 8 hours of tinkering and google searches, it turned out that running

'linux apic'

as the boot command made everything rosy.

Comment 18 meyer@princeton.edu 2002-04-15 18:21:43 EDT
I note the bug is closed.  But it has yet to have it's problem solved!  I tried 
the latest apic bit without any of the other commands and no go.  Still says no 
linux to upgrade.
Comment 19 meyer@princeton.edu 2002-04-15 18:23:18 EDT
When is this bug going to be fixed?
Comment 20 Michael Fulbright 2002-04-16 16:37:04 EDT
Apparently your machine is one which requires the 'apic' option for the 2.4
kernel.  I can assign this issue to the kernel team.
Comment 21 Matt Wilson 2002-04-16 16:40:10 EDT
no, this 'apic' mess is a red herring introduced by a third party
(martyrampton@hotmail.com) that does not understand the problem.

This is going to take some deep hackery in parted's partition detection code.
Comment 22 Arjan van de Ven 2002-04-16 16:42:37 EDT
If this is a 440GX based (Intel) motherboard we cannot fix it. The bios is
broken. Intel needs to fix that. We sort of can work around it, mostly, and
"apic" does exactly that. Ask Intel if they have a fixed bios update available.
Comment 23 Matt Wilson 2002-04-16 16:48:41 EDT
again, that 'apic' bit is a red herring.
Comment 24 Jack Perdue 2002-04-16 18:05:57 EDT
I have the same problem here.  Never got around to trying 
the red herring (the PFY was supposed to and hasn't yet).

Sure enough, it's an Intel 440GX (HP Kayak).  I have the
output from:

-- lspci -vv   (or maybe just one v)
-- fdisk -l 
-- dd if=/dev/sda of=/tmp/foo bs=1M count=1

I can upload if you think it will help.

Comment 25 meyer@princeton.edu 2002-04-17 07:14:50 EDT
Hi, guys!  I've tried the lone 'linux apic' fix - and it doesn't.  HOWEVER... 
although Disk Druid doesn't recognize the drive, and I'm afraid of what will 
happen if I let the new automatic gizadeech give things a try, so haven't even 
attempted to go that route with regard to just doing a clean install (I have a 
hefty DOS disk (IDE) on this box with much data I can't afford to lose or get 
screwed up though most of it's backed up)... Anyway... fdisk DOES recognize the 
drive and even prints the partition table... and I'm wondering what would 
happen if I let fdisk do its thing and just repartition the damn thing using 
fdisk?  I would, of course, lose everything with regard to the various 
applications, motif, etc. that I haven't backed up--not the data, but the apps, 
but I don't want to go that route unless I absolutely have to as it means a 
helluva lot of reinstallation, remembering what I got from where (in cases 
where I was in a hurry and didn't write the locus of something down).  I.e., if 
fdisk will work, I'll go that route despite the bother, but I'd appreciate 
knowing if, after fdisking the drive, the installation would still crap out?  
Ideas and comments anyone?
Thanks!
Comment 26 Andrew Clausen 2002-04-24 18:21:50 EDT
Is the solution to just probe msdos first?  Butt ugly, but solves
the common case problem.

Another option is asking the user, but libparted's exception system
is less-than-pretty for that.

Yet another option is: this HD manufacturer probably put both an x86
and mac partition table on the disk, to be "helpful".  Perhaps we look
for something peculiar about this mac partition table, and say it's
not valid?  I'm not sure if this is doable, since many people might
be using these disks' partition tables.  (i.e. found it "helpful")

Comment 27 Jeremy Katz 2004-06-25 14:29:03 EDT
This should be handled better in current releases.

Note You need to log in before you can comment on or make changes to this bug.