Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 613159 - dhcp client can not obtain address
dhcp client can not obtain address
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
13
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-09 16:41 EDT by Ferry Huberts
Modified: 2010-07-11 10:27 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-11 10:27:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ferry Huberts 2010-07-09 16:41:43 EDT
Description of problem:
with the new kernel the new dhcp client can not obtain an address


Version-Release number of selected component (if applicable):
new kernel (non working): 2.6.33.6-147.fc13.x86_64
old kernel (working): 2.6.33.5-124.fc13.x86_64
dhclient: 12:4.1.1-23.P1.fc13.x86_64


How reproducible:
always

Steps to Reproduce:
1. boot
2.
3.
  
Actual results:
no networking address, interface does not come up

Expected results:
normal networking

Additional info:


setup:
I have a bridge setup in which eth0 is connected to br0, and br0 is connected to a lot of VMs


ifcfg-eth0
==========
DEVICE=eth0
HWADDR=xxxxxxxxxxxxx
ONBOOT=no
TYPE=Ethernet
#BOOTPROTO=dhcp
BRIDGE=br0
DEFROUTE=yes
NAME="System eth0"
UUID=5fb06bd0-0bb0-7ffb-45f1-d6edd65f3e03
IPV6INIT=yes
IPV6_AUTOCONF=no
IPV6_DEFROUTE=yes
PEERDNS=yes
PEERROUTES=yes
DHCP_CLIENT_ID=storage

ifcfg-br0
=========
DEVICE=br0
BOOTPROTO=dhcp
ONBOOT=yes
TYPE=Bridge
DELAY=0
STP=on
Comment 1 Ferry Huberts 2010-07-11 10:27:54 EDT
Sorry for this report.

I forgot that I was running a custom e1000 driver because of report
https://bugzilla.redhat.com/show_bug.cgi?id=528234

I recompiled the driver for the new kernel and it worked again

can close. but please DO work on report
https://bugzilla.redhat.com/show_bug.cgi?id=528234

Note You need to log in before you can comment on or make changes to this bug.