Bug 613195 - firefox always starts in offline mode
firefox always starts in offline mode
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-09 19:48 EDT by Joe Bayes
Modified: 2010-07-09 20:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-09 20:59:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Bayes 2010-07-09 19:48:20 EDT
Description of problem:
Firefox always starts in offline mode, even when the network is working and it was in online mode when it was last used.

Version-Release number of selected component (if applicable):
firefox-3.6.4-1.fc13.x86_64

How reproducible:
always

Steps to Reproduce:
1. Put firefox in online mode
2. quit and restart firefox

  
Actual results:
"Firefox is currently in offline mode and cannot browse the web" appears in all tabs, and File->Work Offline is checked

Expected results:
Tabs should load whatever they were pointing to when I last quit firefox.

Additional info:
I suspect that this may have something to do with my having "Controlled by NetworkManager" unticked for eth0 in system-config-network. Is Firefox assuming that since there is no "managed" network connection, there must be no network connection at all?
Comment 1 Christopher Aillon 2010-07-09 20:59:07 EDT
Correct.  If you are not letting NetworkManager control your interface because of a failing in NetworkManager, please consider filing a bug against it so we can fix it.

If you don't wish to use NetworkManager at all, you should consider turning off the service completely, via either system-config-services or via chkconfig.

Alternatively, if you need to use NetworkManager for some interfaces, you might consider setting the following preference: toolkit.networkmanager.disable to true.

Note You need to log in before you can comment on or make changes to this bug.