Bug 61323 - Internal compiler error
Summary: Internal compiler error
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 7.1
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-18 00:18 UTC by Need Real Name
Modified: 2007-04-18 16:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-18 00:19:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-03-18 00:18:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3sfk i686)

Description of problem:
g++ 2.96-85 reports an internal error while building TAO 1.2 with ACE 5.2.

g++ -W -Wall -Wpointer-arith -pipe -O3 -g -Wno-uninitialized
-fno-implicit-templates   -D_POSIX_THREADS -D_POSIX_THREAD_SAFE_FUNCTIONS
-D_REENTRANT -DACE_HAS_AIO_CALLS  -I/opt/ACE_wrappers/ -DACE_HAS_EXCEPTIONS   
-I/opt/ACE_wrappers//TAO  -c -fPIC -o .shobj/POA_Policies.o POA_Policies.cpp
PolicyS.cpp: In function `void POA_CORBA_Policy::_get_policy_type_skel
(TAO_ServerRequest &, void *, void *, Environment &)':
PolicyS.cpp:894: Internal compiler error in scan_region, at except.c:
2809
Please submit a full bug report.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Get ACE 5.2 + TAO 1.2 Corba orb
2.  Build ACE according to instructions
3.  Build TAO according to instructions
	

Actual Results:  g++ -W -Wall -Wpointer-arith -pipe -O3 -g -Wno-uninitialized
-fno-implicit-templates   -D_POSIX_THREADS -D_POSIX_THREAD_SAFE_FUNCTIONS
-D_REENTRANT -DACE_HAS_AIO_CALLS  -I/opt/ACE_wrappers/ -DACE_HAS_EXCEPTIONS   
-I/opt/ACE_wrappers//TAO  -c -fPIC -o .shobj/POA_Policies.o POA_Policies.cpp
PolicyS.cpp: In function `void POA_CORBA_Policy::_get_policy_type_skel
(TAO_ServerRequest &, void *, void *, Environment &)':
PolicyS.cpp:894: Internal compiler error in scan_region, at except.c:
2809
Please submit a full bug report.
make[2]: *** [.shobj/PolicyS.o] Error 2
...
g++ -D_POSIX_THREADS -D_POSIX_THREAD_SAFE_FUNCTIONS -D_REENTRANT
-DACE_HAS_AIO_CALLS  -I/opt/ACE_wrappers/ -DACE_HAS_EXCEPTIONS   
-I/opt/ACE_wrappers//TAO -shared -o libTAO_DynamicInterface.so  
.shobj/Context.o .shobj/DII_Invocation.o .shobj/DII_Reply_Dispatcher.o
.shobj/Dynamic_Adapter_Impl.o .shobj/Dynamic_Implementation.o
.shobj/ExceptionList.o .shobj/Request.o .shobj/Server_Request.o
.shobj/Unknown_User_Exception.o -L/opt/ACE_wrappers//ace -L./
-L/opt/ACE_wrappers//TAO/tao -lTAO_PortableServer -lTAO -lACE -ldl -lpthread
-lrt
/usr/bin/ld: cannot find -lTAO_PortableServer
collect2: ld returned 1 exit status



Additional info:

Comment 1 Jakub Jelinek 2002-03-20 09:28:44 UTC
This has been fixed since gcc-2.96-97 AFAIK.


Note You need to log in before you can comment on or make changes to this bug.