Bug 613297 - acpid init script checks for /proc/acpi/event - and fails
Summary: acpid init script checks for /proc/acpi/event - and fails
Status: CLOSED DUPLICATE of bug 613315
Alias: None
Product: Fedora
Classification: Fedora
Component: acpid   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jiri Skala
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-10 15:45 UTC by lethalwp
Modified: 2014-11-09 22:33 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-12 06:53:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description lethalwp 2010-07-10 15:45:58 UTC
Description of problem:
the init script of acpid checks for /proc/acpi/event file, which isn't present in the shipped 2.6.35rc kernel,  maybe it has been deprecated and replaced by another way of getting events;  if i remove the check, acpid works ok.


Version-Release number of selected component (if applicable):
acpid-2.0.4-1.fc14.x86_64
on kernel 2.6.35-0.29.rc4.git0.fc14.x86_64 #1 SMP Wed Jul 7 23:00:35 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux


How reproducible:
always

Steps to Reproduce:
1. /etc/init.d/acpid start 
2.
3.
  
Actual results:
nothing shown

Expected results:
'acpid has been started'


Additional info:

Comment 1 Jiri Skala 2010-07-12 06:53:44 UTC

*** This bug has been marked as a duplicate of bug 613315 ***


Note You need to log in before you can comment on or make changes to this bug.