Bug 613372 - No links to recent tasks and builds on summary page
Summary: No links to recent tasks and builds on summary page
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: koji   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-11 02:05 UTC by nucleo
Modified: 2013-01-10 06:04 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-12 14:22:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description nucleo 2010-07-11 02:05:26 UTC
Description of problem:
There are no more links on summary page
"Builds 1 through 50 of 182626 >>>"
"Tasks 1 through 50 of 793503 >>>"

If I just want to see all builds and tasks I can go to Builds and Tasks pages.
But it was more easy to have those links on my summary page, when I logged in, because now if want to see all my tasks I should now go to the tasks page, select all tasks and select owner. 

Version-Release number of selected component (if applicable):
koji-1.4.0-1.fc14

Comment 1 Mike McLean 2010-07-12 14:22:27 UTC
This was done for performance reasons. This page sees a lot of traffic and paginating those results is costly. As you have pointed out, the Build and Tasks pages are more robust.

If you want to go directly to a view of your tasks, you could always bookmark it.

Comment 2 nucleo 2010-07-14 00:18:52 UTC
Can I suggest a feature?

When user is logged in koji web "Built by" and "Owner" on Builds and Tasks pages should be set to user that logged in.

Comment 3 Mike McLean 2010-07-27 15:15:01 UTC
Currently, when a user is logged into the web ui, the second choice in each of those dropdowns is "me," referring to the logged in user. This makes it very easy to select just your tasks or builds.

You can also bookmark the resulting url and go directly there.


Note You need to log in before you can comment on or make changes to this bug.