Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 613429 - Gnome automounter causes kernel crash when two usb btrfs hard drives are attached
Gnome automounter causes kernel crash when two usb btrfs hard drives are atta...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-11 09:58 EDT by Need Real Name
Modified: 2010-11-20 14:05 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-20 14:05:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2010-07-11 09:58:52 EDT
If I log into Gnome while two USB disks are attached, the computer freezes/crashes.

There are no errors shown on the screen. The computer does not respond. The numlock button on the keyboard does not toggle the numlock light.

If I switch to the console vt2 just after entering my password and hitting enter, the crash does not occur - but the disks are also not mounted.

I think there is a race condition caused by both disks being mounted simultaneously.

I suspect this is easy to reproduce (it's happened to me three times so far today).
Comment 1 David Zeuthen 2010-07-12 15:41:36 EDT
Sounds more like a hardware (or kernel) bug. If you have more information, please let us know. In the future, please include sufficient information in the bug report - it's not very useful just guessing at a component. In this case, it can never ever be a D-Bus bug because the D-Bus has nothing to do with hardware.
Comment 2 Need Real Name 2010-07-12 15:53:00 EDT
How can it be a hardware bug? I can mount both disks fine, it's only when whatever mechanism in Gnome mounts both disks simultaneously that the computer crashes.

How do you want me to include sufficient information? Which information do you need?
Comment 3 David Zeuthen 2010-07-12 16:05:56 EDT
(In reply to comment #2)
> How can it be a hardware bug?

By the same token, how can this be a D-Bus bug? I mean, really, how did you even pick D-Bus as the guilty party? Pure guess? That's not a way to file bugs.

> I can mount both disks fine, it's only when
> whatever mechanism in Gnome mounts both disks simultaneously that the computer
> crashes.

The mechanism is not in GNOME, the mechanism is either the hardware or the kernel driver or the privileged storage daemon (and then GNOME is the user of one of these - that doesn't make it GNOME's fault). And the privileged storage daemon (udisks) is simply just running commands that interface with the hardware through the kernel. So it is either the hardware or the kernel.

Please understand that unprivileged code (like GNOME) can *never* lock up the machine like this. Hence, it's useless to file it against unprivileged code. And please understand that a bug without information isn't a useful bug - it's just additional work on already overloaded package maintainers like myself.

> How do you want me to include sufficient information? Which information do you
> need?    

dmesg output for example
Comment 4 Need Real Name 2010-07-12 16:43:08 EDT
> > How can it be a hardware bug?
> 
> By the same token, how can this be a D-Bus bug? I mean, really, how did you
> even pick D-Bus as the guilty party? Pure guess? That's not a way to file bugs.

I misremembered whatever the name of the service is that processes mounts in the gnome gui. I still have no idea what it's called.

> > I can mount both disks fine, it's only when
> > whatever mechanism in Gnome mounts both disks simultaneously that the computer
> > crashes.
> 
> The mechanism is not in GNOME, the mechanism is either the hardware or the
> kernel driver or the privileged storage daemon (and then GNOME is the user of
> one of these - that doesn't make it GNOME's fault). And the privileged storage
> daemon (udisks) is simply just running commands that interface with the
> hardware through the kernel. So it is either the hardware or the kernel.

Yep, so the kernel shouldn't crash, but the <name of whatever mounts things in gnome> might be doing something dodgy. No idea.

> Please understand that unprivileged code (like GNOME) can *never* lock up the
> machine like this. Hence, it's useless to file it against unprivileged code.
> And please understand that a bug without information isn't a useful bug - it's
> just additional work on already overloaded package maintainers like myself.

Yes but you're being so unhelpful I don't know what to do.

The machine is *crashing* in a *gui*. There is no console. There is no dmesg output, the machine has crashed.

> > How do you want me to include sufficient information? Which information do you
> > need?    
> 
> dmesg output for example    

Even kdump isn't doing anything useful.
Comment 5 Need Real Name 2010-07-12 16:54:11 EDT
Bug 613807 filed for kdump problem.
Comment 6 Need Real Name 2010-11-20 12:18:17 EST
I cannot reproduce this problem using ext4.

The following must be true:
* USB devices are encrypted
* Filesystem is btrfs
* Passphrase is already known for current session
Comment 7 Need Real Name 2010-11-20 14:05:21 EST
Please ignore comment 6. I can't reliably reproduce this. Closing.

Note You need to log in before you can comment on or make changes to this bug.