Bug 613472 - option "-no-kvm-pit-reinjection" is not used.
Summary: option "-no-kvm-pit-reinjection" is not used.
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
high
medium
Target Milestone: rc
: ---
Assignee: Daniel Veillard
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-11 22:10 UTC by lihuang
Modified: 2013-01-09 22:51 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-13 10:08:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description lihuang 2010-07-11 22:10:36 UTC
Description of problem:
the option to keep guest time is not used. confirmed with Dor.we need it.


Version-Release number of selected component (if applicable):
libvirt-0.8.1-7.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.start a guest
2.ps -aef | grep qemu-kvm | grep no-kvm-pit-reinjection
3.
  
Actual results:


Expected results:


Additional info:

Comment 2 Daniel Berrange 2010-07-12 10:02:14 UTC
Please provide the XML configuration for the guest in question.

Comment 3 lihuang 2010-07-13 10:08:44 UTC
Hi Daniel

I guess you only care the clock setting in the xml file:)

it is :
<clock offset='utc'/>
Yes. the tick policy is not configrated. (guest is installed from virt-manager. and only "Clock Offset" cound be set from GUI ) 

According to http://www.redhat.com/archives/libvir-list/2010-March/msg00304.html
change to :
  <clock offset='utc'>
    <timer name='pit' tickpolicy='delay'/>
  </clock>

then the option is present.So it is not a bug . at least not libvirt's issue.

Comment 4 Dor Laor 2010-07-13 10:55:54 UTC
So maybe it's within virt-manager


Note You need to log in before you can comment on or make changes to this bug.