Bug 613501 - gcc update to 4.5.0-1 makes yum to stumble upon conflicts in libstdc++ files
Summary: gcc update to 4.5.0-1 makes yum to stumble upon conflicts in libstdc++ files
Status: CLOSED DUPLICATE of bug 612720
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-12 03:45 UTC by Michal Jaegermann
Modified: 2010-07-12 06:26 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-12 06:26:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Jaegermann 2010-07-12 03:45:33 UTC
Description of problem:

With both x86_64 and i686 variants of libstdc++ installed an update attempt bumps into the following yum errors:

Transaction Check Error:
  file /usr/share/gcc-4.5.0/python/libstdcxx/__init__.pyc conflicts between attempted installs of libstdc++-4.5.0-1.fc14.x86_64 and libstdc++-4.5.0-1.fc14.i686
  file /usr/share/gcc-4.5.0/python/libstdcxx/__init__.pyo conflicts between attempted installs of libstdc++-4.5.0-1.fc14.x86_64 and libstdc++-4.5.0-1.fc14.i686
  file /usr/share/gcc-4.5.0/python/libstdcxx/v6/__init__.pyc conflicts between attempted installs of libstdc++-4.5.0-1.fc14.x86_64 and libstdc++-4.5.0-1.fc14.i686
  file /usr/share/gcc-4.5.0/python/libstdcxx/v6/__init__.pyo conflicts between attempted installs of libstdc++-4.5.0-1.fc14.x86_64 and libstdc++-4.5.0-1.fc14.i686
  file /usr/share/gcc-4.5.0/python/libstdcxx/v6/printers.pyc conflicts between attempted installs of libstdc++-4.5.0-1.fc14.x86_64 and libstdc++-4.5.0-1.fc14.i686
  file /usr/share/gcc-4.5.0/python/libstdcxx/v6/printers.pyo conflicts between attempted installs of libstdc++-4.5.0-1.fc14.x86_64 and libstdc++-4.5.0-1.fc14.i686

and that breaks the whole transaction which would include those packages. Getting around that is not easy.

Files in questions appear to be really different as after "forcing" the issue one sees from "rpm -V libstdc++-4.5.0-1.fc14.x86_64" the following:

..5......    /usr/share/gcc-4.5.0/python/libstdcxx/__init__.pyc
..5......    /usr/share/gcc-4.5.0/python/libstdcxx/__init__.pyo
..5......    /usr/share/gcc-4.5.0/python/libstdcxx/v6/__init__.pyc
..5......    /usr/share/gcc-4.5.0/python/libstdcxx/v6/__init__.pyo
..5......    /usr/share/gcc-4.5.0/python/libstdcxx/v6/printers.pyc
..5......    /usr/share/gcc-4.5.0/python/libstdcxx/v6/printers.pyo


Version-Release number of selected component (if applicable):
libstdc++-4.5.0-1.fc14

Comment 1 Jakub Jelinek 2010-07-12 06:26:59 UTC

*** This bug has been marked as a duplicate of bug 612720 ***


Note You need to log in before you can comment on or make changes to this bug.