Bug 61352 - PCL, ESCape codes interpreted as text by Windows LPD queue
PCL, ESCape codes interpreted as text by Windows LPD queue
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: printconf (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-18 07:21 EST by Mathijs
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 10:08:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mathijs 2002-03-18 07:21:37 EST
Description of Problem:
When I print postscript with lpr to a remote Windows NT LPD queue,
having the correct printer specified with printconf (in my case HP4050
and HP8000), the printer prints the file and the control codes as text.

Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. install correct printerdriver with printconf with remote windows LPD service 
2. print postscript file
3.

Actual Results:
file is printed as text

Expected Results:
file is printed as postscript

Additional Information:
Work-around/fix:
if
:translate_format=fl:
is added to every remote printer in /etc/printcap everything is OK.

(other) possible solution:
the LPR print control file sent to the windows LPD service should
contain the l control command instead of the f control command if the remote
queue is a windows LPD service.

From the windows LPD service documentation:
LPD receives jobs from LPR clients and submits them to the spooler. LPR clients
always send a "control file" (actually, a data structure within the print job) containing administrative information with each print job. LPD assigns a 
data type based on the control commands in that control file.
If the client sends the f, o, or p control command, the LPD assigns the TEXT data type to the print job--which tells the spooler to edit the job to 
make sure it prints. If the client sends the l control command, the LPD assigns the RAW data type to the print job--which tells the spooler the print 
job needs no editing to print correctly. For more detail about data types, see "Data Types" earlier in this chapter.
Control commands are documented in the LPR specification, Request For Comment (RFC)1179, sections 7.17 through 7.29. For detailed information about RFC 
1179, refer to the Windows NT Knowledge Base article, "Text of RFC1179 Standard for Windows NT TCP/IP Printing," reference number Q124734.
Note   Notice that all the control commands defined in RFC 1179 are case sensitive. Notice also that many printer languages, including PCL, rely heavily 
on the
ESC control character, which the f control command causes to be filtered from the print job. Do not use the f control command when sending print jobs 
that contain printer commands.
Because LPD assigns a data type explicitly, the default data type found in the Print Processor dialog box has no effect on print jobs received by LPD. 
To change the behavior of LPD, you must reconfigure the LPR client application to send a
different control command with the print job. To reconfigure a LPR client application, consult the documentation for the application.
Comment 1 Tim Waugh 2002-03-20 03:15:16 EST
Thanks for the report.  I've seen previous reports of similar symptoms, and I
wonder if it's just as simple as the translate '\n'->'\r\n' option being set
when it shouldn't be?  I think it's on by default at the moment, but that's
probably wrong.  Could you try unsetting it and see if that makes a difference?

(The printcap entry addition looks like a good thing to do as well: thanks for
pointing that out.)
Comment 2 Mathijs 2002-03-20 03:47:38 EST
I'd like to try it, but please tell me how to change this option. It already took 
me quite some time to find out f/l work-around.
Comment 3 Tim Waugh 2002-04-04 09:41:17 EST
Oh, I'm thinking of SMB print queues, which is something different.
Comment 4 Bill Nottingham 2006-08-07 13:07:30 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 5 Bill Nottingham 2006-10-18 10:08:54 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.