Bug 613524 - Cursor position does not move forward when typing '309b' in Evolution
Summary: Cursor position does not move forward when typing '309b' in Evolution
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ibus-rawcode   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Pravin Satpute
QA Contact: QE Internationalization Bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-12 07:02 UTC by Kenichi Takemura
Modified: 2014-08-04 22:02 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-12 07:23:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen shot of the actual result (91.50 KB, image/png)
2010-07-12 07:03 UTC, Kenichi Takemura
no flags Details
Screen shot of the expected result (134.09 KB, image/png)
2010-07-12 07:03 UTC, Kenichi Takemura
no flags Details

Description Kenichi Takemura 2010-07-12 07:02:18 UTC
Description of problem:

Cursor position does not move forward when typing '309b' in Evolution and Firefox (Search box)

3042「Space」309b「Space」309e「Space」

If you do the same thing in Gedit, it works.

Version-Release number of selected component (if applicable):

RHEL Version:Red Hat Enterprise Linux Workstation release 6.0 Beta (Santiago)
Kernel:2.6.32-37.el6.x86_64
Package: ibus-rawcode-1.3.0.20100421-2.el6.x86_64


How reproducible:

100%


Steps to Reproduce:
1. Open Evolution and Compose message
2. Turn Ibus on with ibus-rawcode.
3. Type 3042「Space」309b「Space」309e「Space」


Actual results:

あ゛あ is displayed(attachment actual_result.png). When hitting space after '309b' the cursor does not move and you need to hit another space to move it forward. If so あ゛ あ is displayed(attachment actual_result.png).
But,
- " occupies only half byte but it should do full byte like あ? 
- Deleting " is quite wired because of the cursor position. 

Expected results:

Type 3042「Space」309b「Space」309e「Space」 should display like attachment(expected_result.png).

" occupies full byte not half byte.

Additional info:

Comment 1 Kenichi Takemura 2010-07-12 07:03:05 UTC
Created attachment 431087 [details]
Screen shot of the actual result

Comment 2 Kenichi Takemura 2010-07-12 07:03:42 UTC
Created attachment 431088 [details]
Screen shot of the expected result

Comment 4 Pravin Satpute 2010-07-12 07:23:48 UTC
this is not a valid bug

1) 309B  ; [*0220.0020.0002.309B] # KATAKANA-HIRAGANA VOICED SOUND MARK

this character (as per font) always appear right to current cursor. 
Even if one type same single character (309b) in gedit, you cant move cursor to
its right since it is designed in that way



1) ibus-rawcode is just inputs character to editor (gedit, evolution, kwrite
etc.)

then cursor movement is handled by corresponding editor's rendering engine
(pango, qt etc)


Note You need to log in before you can comment on or make changes to this bug.