Bug 613567 - mock rebuild against fedora-rawhide-i386 fails
Summary: mock rebuild against fedora-rawhide-i386 fails
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: maven-remote-resources-plugin   
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: huwang
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 613566 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-12 09:53 UTC by Spike
Modified: 2010-07-16 08:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-16 08:49:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build log (123.28 KB, text/plain)
2010-07-12 09:53 UTC, Spike
no flags Details
one of failing test results (19.74 KB, text/plain)
2010-07-12 13:08 UTC, Stanislav Ochotnicky
no flags Details
Patche to fix building of tests (1.08 KB, application/octet-stream)
2010-07-12 13:11 UTC, Stanislav Ochotnicky
no flags Details
depmap needed to actually build tests (531 bytes, application/octet-stream)
2010-07-12 13:11 UTC, Stanislav Ochotnicky
no flags Details

Description Spike 2010-07-12 09:53:24 UTC
Description of problem:
Rebuilding the source rpm against fedora-rawhide-i386 fails.

Steps to Reproduce:
1. mock -r fedora-rawhide-i386 --rebuild rpmbuild/SRPMS/maven-remote-resources-plugin-1.1-2.fc14.src.rpm
  
Actual results:
see build.log

Comment 1 Spike 2010-07-12 09:53:58 UTC
Created attachment 431125 [details]
build log

Comment 2 Spike 2010-07-12 09:55:49 UTC
*** Bug 613566 has been marked as a duplicate of this bug. ***

Comment 3 Stanislav Ochotnicky 2010-07-12 12:07:40 UTC
Build fails on test compilation. You will either have to patch test stubs or skip tests completely. With -Dmaven.test.skip=true package builds fine.

Comment 4 Stanislav Ochotnicky 2010-07-12 13:07:52 UTC
Hmm, I was able to get a bit further. By patching stub, adding one more dependency to pom.xml and using custom depmap I was able to get a bit further. It looks like plexus-containers are not working correctly with new maven. See attached test output.

Comment 5 Stanislav Ochotnicky 2010-07-12 13:08:42 UTC
Created attachment 431167 [details]
one of failing test results

Comment 6 Stanislav Ochotnicky 2010-07-12 13:11:11 UTC
Created attachment 431172 [details]
Patche to fix building of tests

Comment 7 Stanislav Ochotnicky 2010-07-12 13:11:52 UTC
Created attachment 431175 [details]
depmap needed to actually build tests

Comment 8 huwang 2010-07-13 03:30:13 UTC
Fixed.
Thank Stanislav for the explain.

Comment 9 Stanislav Ochotnicky 2010-07-13 07:16:21 UTC
Actually until plexus containers are updated this fix will only workaround build failures, but remote-resources will not work anyway (IMO). At least it seems like plexus-containers issue to me.

Comment 10 Stanislav Ochotnicky 2010-07-16 08:49:06 UTC
Should be fixed in rawhide


Note You need to log in before you can comment on or make changes to this bug.