Bug 613662 - [abrt] crash in tortoisehg-1.1-1.fc13: csinfo.py:425:try_cache:AttributeError: 'NoneType' object has no attribute '_repo'
[abrt] crash in tortoisehg-1.1-1.fc13: csinfo.py:425:try_cache:AttributeError...
Status: CLOSED DUPLICATE of bug 580040
Product: Fedora
Classification: Fedora
Component: tortoisehg (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Mads Kiilerich
Fedora Extras Quality Assurance
abrt_hash:070afab7
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-12 10:24 EDT by Mads Kiilerich
Modified: 2010-07-12 10:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-12 10:40:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.60 KB, text/plain)
2010-07-12 10:24 EDT, Mads Kiilerich
no flags Details

  None (edit)
Description Mads Kiilerich 2010-07-12 10:24:04 EDT
abrt 1.1.1 detected a crash.

architecture: i686
cmdline: /usr/bin/python /usr/bin/hgtk log
component: tortoisehg
executable: /usr/bin/hgtk
kernel: 2.6.33.6-147.fc13.i686.PAE
package: tortoisehg-1.1-1.fc13
reason: csinfo.py:425:try_cache:AttributeError: 'NoneType' object has no attribute '_repo'
release: Fedora release 13 (Goddard)

backtrace
-----
csinfo.py:425:try_cache:AttributeError: 'NoneType' object has no attribute '_repo'

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/tortoisehg/hgtk/changeset.py", line 273, in filelist_rowchanged
    self.generate_change_header()
  File "/usr/lib/python2.6/site-packages/tortoisehg/hgtk/changeset.py", line 301, in generate_change_header
    desc = self.summarypanel.get_data('desc')
  File "/usr/lib/python2.6/site-packages/tortoisehg/hgtk/csinfo.py", line 477, in get_data
    return self.info.get_data(item, self, self.ctx, self.custom, **kargs)
  File "/usr/lib/python2.6/site-packages/tortoisehg/hgtk/csinfo.py", line 450, in get_data
    return self.try_cache('data', SummaryInfo.get_data, *args, **kargs)
  File "/usr/lib/python2.6/site-packages/tortoisehg/hgtk/csinfo.py", line 425, in try_cache
    root = ctx._repo.root
AttributeError: 'NoneType' object has no attribute '_repo'

Local variables in innermost frame:
widget: <SummaryPanel object at 0xa57d52c (GtkFrame at 0xa5989a0)>
kargs: {}
self: <tortoisehg.hgtk.csinfo.CachedSummaryInfo object at 0xa576bec>
args: ('desc', <SummaryPanel object at 0xa57d52c (GtkFrame at 0xa5989a0)>, None, {'markup': <function markup_func at 0xa56d56c>, 'data': <function data_func at 0xa56d4fc>, 'widget': <function widget_func at 0xa56d5a4>, 'label': <function label_func at 0xa56d534>})
ctx: None
custom: {'markup': <function markup_func at 0xa56d56c>, 'data': <function data_func at 0xa56d4fc>, 'widget': <function widget_func at 0xa56d5a4>, 'label': <function label_func at 0xa56d534>}
item: 'desc'
func: <unbound method SummaryInfo.get_data>
target: 'data'
Comment 1 Mads Kiilerich 2010-07-12 10:24:07 EDT
Created attachment 431188 [details]
File: backtrace
Comment 2 Mads Kiilerich 2010-07-12 10:40:10 EDT

*** This bug has been marked as a duplicate of bug 580040 ***

Note You need to log in before you can comment on or make changes to this bug.