Bug 613692 - SELinux is preventing /sbin/setfiles access to a leaked /tmp/tmpJAAvSS file descriptor.
SELinux is preventing /sbin/setfiles access to a leaked /tmp/tmpJAAvSS file d...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:a9bb3664c1f...
:
: 613687 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-12 11:18 EDT by Steve
Modified: 2010-12-08 12:59 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-29 11:06:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve 2010-07-12 11:18:01 EDT
Summary:

SELinux is preventing /sbin/setfiles access to a leaked /tmp/tmpJAAvSS file
descriptor.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by the setfiles command. It looks like this is
either a leaked descriptor or setfiles output was redirected to a file it is not
allowed to access. Leaks usually can be ignored since SELinux is just closing
the leak and reporting the error. The application does not use the descriptor,
so it will run properly. If this is a redirection, you will not get output in
the /tmp/tmpJAAvSS. You should generate a bugzilla on selinux-policy, and it
will get routed to the appropriate package. You can safely ignore this avc.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385)

Additional Information:

Source Context                system_u:system_r:setfiles_t:s0-s0:c0.c1023
Target Context                system_u:object_r:initrc_tmp_t:s0
Target Objects                /tmp/tmpJAAvSS [ file ]
Source                        setfiles
Source Path                   /sbin/setfiles
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           policycoreutils-2.0.83-1.fc14
Target RPM Packages           
Policy RPM                    selinux-policy-3.8.6-1.fc14
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   leaks
Host Name                     (removed)
Platform                      Linux (removed) 2.6.35-0.31.rc4.git4.fc14.i686.PAE
                              #1 SMP Fri Jul 9 01:18:51 UTC 2010 i686 i686
Alert Count                   1
First Seen                    Mon 12 Jul 2010 05:17:28 PM CEST
Last Seen                     Mon 12 Jul 2010 05:17:28 PM CEST
Local ID                      60146886-3938-4e97-83d3-95722bbd2d98
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1278947848.718:24225): avc:  denied  { read append } for  pid=2212 comm="setfiles" path="/tmp/tmpJAAvSS" dev=dm-0 ino=1966100 scontext=system_u:system_r:setfiles_t:s0-s0:c0.c1023 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1278947848.718:24225): arch=40000003 syscall=11 success=yes exit=0 a0=1723298 a1=8029500 a2=0 a3=0 items=0 ppid=2192 pid=2212 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="setfiles" exe="/sbin/setfiles" subj=system_u:system_r:setfiles_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  leaks,setfiles,setfiles_t,initrc_tmp_t,file,read,append
audit2allow suggests:

#============= setfiles_t ==============
allow setfiles_t initrc_tmp_t:file { read append };
Comment 1 Miroslav Grepl 2010-07-12 12:12:44 EDT
Were you installing/updating packages with PackageKit?
Comment 2 Miroslav Grepl 2010-07-12 12:13:01 EDT
*** Bug 613687 has been marked as a duplicate of this bug. ***
Comment 3 Steve 2010-07-12 12:22:01 EDT
On(In reply to comment #1)
> Were you installing/updating packages with PackageKit?    

Only rawhide.
Comment 4 Christoph Wickert 2010-07-14 12:24:35 EDT
I'm on F13 and I see this error every time I boot after updating to selinux-policy-3.7.19-33.fc13.noarch
Comment 5 Daniel Walsh 2010-07-14 14:12:10 EDT
This is caused by the moving of packagekitd to a different directory.

ls -lZ /usr/libexec/packagekitd
Comment 6 Miroslav Grepl 2010-07-15 16:51:19 EDT
(In reply to comment #4)
> I'm on F13 and I see this error every time I boot after updating to
> selinux-policy-3.7.19-33.fc13.noarch    

Fixed in selinux-policy-3.7.19-37.fc13

selinux-policy-3.7.19-37.fc13 has been pushed to the Fedora 13 testing
repository.  If problems still persist, please make note of it in this bug
report.

If you want to test the update, you can install it with 

su -c 'yum --enablerepo=updates-testing update selinux-policy'.  

You can provide feedback for this update here:
http://admin.fedoraproject.org/updates/selinux-policy-3.7.19-37.fc13

Note You need to log in before you can comment on or make changes to this bug.